Chevrolet Questions

Answered Chevrolet Questions

Ask a Question
View:RecentAnsweredUnanswered
I've replace distributor, ignition module and coil I've replace fuel filter, map sensor, fuel pump relay fuse, and I'm still having the same problem
The oil is not low, and I do not hear any sound. Thank you
i bought my car 2 weeks ago off of Craig's list and the owners of the car don't want to help me out by telling me what's wrong with my car. All they told me was that if the car turned off on me that it was okay to ...
In "learned key info"(DDS2), Valid key - yes. It is new key, cut and learned to "master".
1991 Silverado5.7 rebuilt engine with a RV grind knok sensor code upon install replaced wires and sensor also got another module to test still shows knok sensor code engine seems to run smooth any advice
is it thermostat/ gas cap/ or is it something else...check light is on
My 95 chevy s 10 4.3 Z Started running really bad sometimes to the point it will shut off. The transmission stops shifting like it should when this is going on. I was told that the temp control sensor was bad. I repla...
add a bigger cam and put some 350 head on it is that possible?
What are some signs of a leaking head gasket or a blown gasket? I'm trying to fix my 08 Malibu and I need some answers.. The oil looks like chocolate on the dipstick..
problem does not occur often, once a month, I do notice when I start it, it sounds like its not gonna start, but it always starts.help dashboard shows no kinda warning signs.
When I turn the ignition off and open the door the radio and lights and dome stay on like key was in acc position tes.
i was told it was located under the motor by the starter, nope
I have 183000 miles on the car. It is strong with a good engine but when I takeoff or pick up speed it jumps a little .What to do?
Recharged with can of A/C Pro, still only hot air!! Pump seems to be working due to compressor getting super cold!!!
i am hopping that the timing is off because i am getting nervious i hired some hafe ass thinking he new .
it has a 454 and edelbrock camshaft lifter kit and seems not to be keeping proper oil pressure
They said broken main bearing bolt. Anyone have any experience with this? Worried about metal pieces in engine causing problems later. They are replacing the crank shaft balancer.
because i just had my brake sensor replaced and my gear will not go into drive, it's stuck in park
air conditioner only blows on high speed