The alarm begins to sound i was getting a new key made but never did i decided to wait for my wife to return from out of state with the original key but i think the chip is not matching up or something the lock smith may have changed the code for the chip now my chip isnt working is there a quick fix

is there anything I can put in the tank when I fill it up that could possible clean it up if it gummed up from setting awhile with that ethanol fuel in it?

When I turn the key it does nothing what could be wrong?

My OEM blower motor went out on my 99 sts. It just kept getting slower and louder. So I had it replaced with an aftermarket part purchased at Amazon. That blower worked fine for about a week and went kaput. I could not get continuity through the windings. It only cost $66 for the installation but I am attempting to replace the new one. It is very close quarters. I removed the glove compartment, which probably wasn't necessary, but I now want to remove the DIM box and can't figure out what holds it in. Got any ideas? Thanks, Mike

I have refelled coolent two times and still running hot. once car reachers opt. temp no water leaks from any were. I not sure how to get air out of systems.

this the first time this has happened

2000 Cadillac Seville Sts, Water pump has been changed along with thermostat, New fans Put on the car and also a new temp sensor. Cluster gauge is reading that the car is hot. goes 3/4 of the way to red. Never no sign of overheating still runs fine and all. So could a bad cluster cause the temp gauge to read wrong?????

others say the motor will have to be pulled to get to it

Had car in shop. Top hose clamp was lose on rad. Care was idling at shop 30 minutes no leak. Drove 4 miles home, parked, antifreeze leaked on driveway. Could it be the rad or trans cooler?

I recently took my car to a repair shop to get the brake pads changed, a tune-up, and my windshield wiper stopped working. They couldn't get my windshield wipers to work and in the process of trying to fix that the battery went dead and somehow messed up the computer. The keys will not crank the car. Both the keys and the computer has been programmed and it still doesn't work. When I purchased the car the only key I was given was a Pontiac key, ,which has been working fine up until now. I replaced the ECM in the car because the windows along with several other electrical parts stop working in the car. Once that problem was fixed everything was working again except the windshield wipers. My vehicle is now at a Chevrolet dealer who can't seem to get the key to crank the car and all they are doing is adding on labor charges and not fixing the problem.

code say speed sensor low voltage

Drove to store, came home, parked, then left back out to go back to store but car would not start at all or crank over, "No Nothing!!" Please help me, is it my STARTER or something else.

Msg. me here or email me professionaltaxpreparer.ninaj@gmail.com

my mechanic as changed some type of switch three times and set idle on computer, but after driving a little the car does same thing.

dashboard not working?

When I'm driving the car idle high then it gets sluggish and take a while to accelerate then it backfires and shut off then it starts back up and continues to do that every day

Car has been over heating...replaced water pump and hoses, also did a flush. Everything was fine for a month or so, then had metal hoses replace...car ran fine again after a long distance trip. Now, car is back to over heating with the oil light blinking on and off...could it be oil pump? Also schedule to have head gasket replaced due to the over heating issue...to be on the safe side...err on the side of caution...