Could this be electrical? How do I investigate the cause?

Desser 10-7-2014

I completely have no brakes.

I have a 1996 Buick Roadmaster 350 LT1 5.7, I am having some issues with the vehicle idling rough and seems to be missing. When I turn on the AC the car runs a little better and sometimes after shutting the AC OFF THE CAR SHUTS OFF.I went to AutoZone and had my car put on the computer and I got a EGR code P0400, Mass Air Flow code P0100, and a Catalyst code P0430. I replace the EGR, and mass air flow sensor, and my car is still doing the same thing. I was also told I may have a leaky water pump. I just recently installed new AC DELCO plugs and wires and a new air filter. Any ideas on what to try next or what could be my problem?

See a video of my car running at


Is there enough room to clear the pick-up tube by raising the engine in the vehicle or will I need to separate the trans to get the engine high enough.

when I got into my car my right blinker wont shut off an my left wont come on and brake lights wont come on either and I changed my bulbs and my break light switch so what could be the problem

I drained old fluid out and changed all gaskets. now I just need to add fluid

Have checked fuses inside car and nothing shows blown. Air conditioner worked fine until today. Any ideas on what could be the problem??

replaced starter and coil, battery is brand new, also new icm

oil pressure is not stable

I was driving car started to "PUTT" I got home ..cut it off . It never cut back on .my boyfriend kept trying to start it . It started to make some " Cat Scream sound". Mechanic came and replaced the starter...still wont start ... he said he thinks my engine is locked..

Is there any other way we can lubricate it instead of spend 4000 plus to get it fixed

Ps. I did get a oil change 1 month prior ..then oil light came back on ...


locating heater control valve on 1992 Buick roadmaster?

if usend picture woul be even much better

When I charge my air conditioning system, it gets cold for about a day and a half and then nothing. I'm fairly certain it's a leak, as this has happened several times even after replacing compressor. Thanks.

at, speed runs well, just during idle, oilpressure drops, engine idles rough and stalls.

fuse for transmission on a 1994 Buick Roadmaster

6-8 X during a 40 mile trip.

When driving 40 miles at night it happened 8-10 times yesterday.

noise. Sometimes it will not make noise &when you start driving and hit a bump in the road it's get noisey again. When you shut it off it squeels & then goes off. What should I do?

it backfire as i give it gas to as it jerks what is that making it do that?

when i crank my car and put it in first gear and as it start to take off,its start to jerking at the speed of 20 and as i try to give it more gas it start jerking. what could be the problem?

Have Installed New fuel pump,crank sencer,key and switch,

Is the valve bad?? Also this Buick has climate control and is not a manual control heat or cooling system. Over the last three to four years getting less and less heat until NONE these last few days as its colder outside. Engine temp is fine as temp guage fluctuates up and down slightly which indicates thermostat is ok. Engine does not over heat and radiator warms up all over equally which indicates radiator is not plugged up. Any suggestions??