BMW 325xi Questions

Answered BMW 325xi Questions

Ask a Question
View:RecentAnsweredUnanswered
It will start when I put starter fluid in and shuts off.
What can be the cause of that? I thought it was because I had bent rims and a bubble on one of the tires. I fixed those problems and the vibrations still persist. I also get a burning smell of rubber.
In first and second gear it's really bad, but when I go faster it stops grinding. The grinding is so rough you can feel it from the inside of the car.
Same issue found trying to buy this vehicle (from 2nd owner). Must have been that way for some time as oil leak and tears at boot joints were moderate, despite owner claiming to have just had the 85k check up done, ne...
coolant recovery tank replaced 1 year ago, cracked by mechanic during air filter replacement...for awhile coolant leaking I have to add some almost everyday. Shop wants to replace waterpump(its seeping) 2 belts, they ...
My 2005 325xi has 145K miles on it. There appears to be no real guidance on the scheduled maintenances after schedule II. Would should i do? i know my car needs a flush of the anti-freeze and power steering fluid base...
Car now has 94K miles. Seemed to occur after an extreme cold spell that was so cold my car wouldn't turn over without a jumpstart
does this model have an anti theft system? i dont have the manual for the car
My '01 325xit has been nearly trouble free for 189,000 miles. (Two window motors replaced as stated in the other comments.) It was running great, until I brought the car in for brakes and an alignment, and they found ...
1. when the speed goes above 60mph, the front of the car starts to vibrate. i can also feel vibration beneath the car. i even got the balance and rotation test done recently. but one month after the test i have t...
It's intermittent and tough to replicate, but it's audible with the windows down and it sounds as if it's coming from the passenger side as well. I can feel the noise slightly through the steering wheel as well. Also...
Could this have been damaged when my transfer case and rear drive shaft were replaced under warranty?
I went to my car one morning and it wasn't starting I then realized it was the. Brake switch so then I repaired it and drove it for 2 days then it didn't start again I'm getting all power in my car everything works ju...
the light just illuminated today after i had not driven the car for about 2 weeks is this serious and do i need to get the brake system all checked
I just purchased my BMW 325xi. I know the chassis number is E-90, but I don't have the Engine designation for the 3.0. I haven't been able to find it. Can you help??
The car stops running after a few minutes of driving, it will re start and drive again and stall again, all light come on dash including pdf indicator..
iv looked to see if anyone else has but i can't find any online only of the 325i
i have driven car city 5 miles city about 40 t0 60 kmh hyghway 10 miles at 100 kmh did about 3 cycles with cold starts here temp outside is -10 6 to 8 hours apart
had code 2096 but could not find nothing so reprogrammed computer with upgrades now driven car for over a week of city and highway but evap cat and air not ready any idea how long this would take
It will eventually start if I shake the steering wheel and/or the steering column while I am turning the key. Sometimes it starts right away other times it takes several tries. Occasionally I only need to mess with ...
I also replaced the fuel pump relay switch as well. Please help me I just bought this car.
into the fuel system and causing blue smoke to come out of the emission pipe. We were told it would take $2200 to repair it. They also said since it is a BMW they recommend the engine be replaced since it is so diffic...
A couple weeks ago I took my car for an oil change and the next day when turmning on my car the car started shaking, trembeling and car would turn off when came to a complete stop. So I took it in again, they said it...
The car still handles good on dry roads. When you hit slush or snow it feels like it all over the road like the rear end is loose. Had it checked everything seems ok. Do I need an alignment? Most threads indicate no...