1,154
questions

The vinyl on my armrests is separating from the padding and peeling back. Can it be repaired or does it have to be replaced?

went to work car was fine got home went back to car won't start all sounds like it wants to but doesn't

We just purchased this vehicle and love it. Not sure how to turn off the 'check' engine light. Any advice?
Also, the fuse seem to blow after we put the windows down or up. We replaced the fuse a few times and keeps blowing? Any helpful advice?

when it rains or my bmw gets wet my tempature goes down to a -40 & lower. This causes the air to go off.Why does this happen?

thats it. so someone please tell me and dont tell me to look inthe manual i dont have one

drivers side turn signal is blinking on the rear but not on the front and the iunsicde display shows that it is out how do i change that bulb??

what does it take to pull and replace front transmission pump seal in a 1991 bmw 325i

My daughter is on a summer mission trip with her '95 325 and her ac fan stopped working. I understand that the ac compressor is still working. Any suggestions? Thank you.

IT WOULD'NT START BAC NOT EVEN WITH STARTING FLUID. WHEN CHECK THE FUEL PUMP HAD BLOWN OUT. IT WAS REPLACED 2X SOMETHING WAS SHORTING IT OUT. NEXT THE FUSE BOX HAD BEEN REPLACED ALONG WITH SOME WIRES AND ALL RELAYS AND FUSES IT STILL WONT START. THE ENGINE IS RECIEVING TO MUCH FUEL WITCH MADE IT FLOOD. IT SEAT OVER NIGHT TO DRY AND STILL WONT START. SPARK PLUG WERE WORN SO THEY WERE REPLACED AND STILL THE CAR WONT START. THE ENGINE JUST TURNS OVER AND CRANK AND THATS IT. EVERYTHING BASIC WAS CHECKED OUT BUT MY MECHANIC CANT FIND THE PROBLEM. CAN SOME INE PLEASE LET ME KNOW HOW TO RESOLVE THIS ISSUE???

Is a power steering "system change" and flush at 60,000 miles a normal maintenance requirement? Thanks!

How do I replace the power steering pump myself

When stopped at a light, if I try and lightly lift off the brake pedal to inch up, the brake gets stuck and the car won't softly move up it sort of jerks up. Any thoughts.

A couple days ago the engine oil pressure light came on blinking red when I was stopped at a light. (only 69,000 miles on the car) When I accelerated to turn through the intersection the light went out then came on blinking again when I was stopped at the next intersection. Again it ceased after I accelerated through the intersection. I pulled into a parking lot and parked. The light came on blinking red again then quit. I turned the motor off and let it sit for a couple hours in the parking lot. When I returned to start it the light never came on again but now there was white smoke coming from the exhaust. It didn't smoke as I drove home (only a couple miles). Over the last 2 days when I start the engine there usually is a great cloud of white smoke coming from the exhaust but not every time. We had a mechanic take a look at it and he found nothing. My husband checked the oil level and it was good. Today a friend followed as we drove and he reported smoke coming out from the exhaust as the car accelerated. Can anyone help?

Windshield washer fluid is leaking near the wasker tank pump. Any suggestions

My washer reserve tank was clogged with algae so I removed and cleaned. I reinstalled as remove, now the tank leakes
near the pump or the pump leaks. Any suggestions?

where is the engine oil dip stick found?

my check engine is on the car start ok but is runing bad

rear window will not go up

My car overheats after 20 minutes in idle and it appears to leak from underneath the throttle body unit. I removed the large coolant hose that connect to the housing unit to the fire wall and it appears fine. Is there another coolant hose around that area? Is there a diagram somewhere online that shows all of the hoses for the coolant system? Thanks.

how do you get at the cylinder lock drivers door can not reach it is there some secret to it. door lock broken would like to replace it. thanks

I just changed brake pads and sensors on my 2006 325i and the brake light won't go off. Can someone tell me how to get this stupid light off?

When driving home last night all the dash lights came on and the rev-counter speedo etc all zero'd for a second (it was same when i first start the car and the key is in the 2nd position) but the engine stayed running and i continued my journey - it seemed very strange as they was not even a drop in power or anything else, it just seemed electrical. It happened again to me this morning on my way into work, i had my foot down this time merging onto a motorway but again the car kept going without even a stutter.......What could be wrong?? please help.

my driver side, and NOW passenger side windows are broken. The doors have been taken off and windows pushed up, its the little black plastic pieces that have broken (to pull the window up it goes down just fine of course) can i find those pieces anywhere? or do i have to have the whole thing replaced? i heard its very expensive, and this is extremely common for bmws

Went for a drive in the Cali mts last week with my automatic 2004 325i sedan. It has less than 53k miles on it. When I started it back up after a short hike, the engine light and another light (gear light?) was on.

When accelerating from 0-25 mph, the car struggled and just didn't pick up speed like a good Bimmer should(merging onto the 101 at a staggering 20 mph was fun, let me tell you!).

Took it into the dealer. They re-programmed the computer (just in case) and determined it was in fact a transmission issue (duh... as if burnt transmission fluid in there wasn't indicative enough).

Anyway, anyone else ever have probs like this with the transmission? Isn't this kind of strange for such low mileage?

When driving at different time the car will have a chime go off 3 times any idea what it means?

Every time I accelerate onto the freeway, the engine cuts out, EML light comes flashing on, and enters limpmode. It then runs rough and surges rpm's until i turn off car and then back on. Started after I was getting p0171 & p0174 codes. replaced vacuum hose, MAF, fuel pump, O2 sensors.

We checked the fuse that was not the problem. We used a voltage meter that measured 12 volts across it when the car was off. When the car was turned on and the power washer switch was turned on it had 31 volts. The pump (that is 12 volts) also isn't working at all. What do we need to do to fix the problem?

how to change fuel pump

the transmission shifts real hard andtransmission warnig light is on

I am attempting change the thermostat.