545
questions

Also is wearing my tyres out prematurely. I think maybe the stearing rac may need rebuilt. I need confirmation from someone who has had experience with Audi's in the past and who may have an idea on cost.

I replaced the flasher switch and it still makes a buzzing noise. And i still have no blinkers.

Recently changed hose between power steering pump and engine block. Loud groaning and super stiff steering. Dont believe it is the pump, and have tried flushing reservoir and turned wheels lock to lock many times. after that, noise stops until i drive.

where is cam position sensor b located

location to replace

For a 2006 Audi A6 Quatro with less than 50,000 miles; what would the expected service life be for the front upper control arm bushings in the suspension system

Car was running amazing. Shut it off in my driveway for a minute. I just got the car so i wanted to start it up again. But when i turned the key a weird noise came from the fuse area and won't even turn over. The battery is charged and radio/headlights, etc all work. I have no idea what the problem is. Serpentine belt does squeak btw and the warning light for washer fluid and dynamic headlight dimmer control not functioning appeared when the car was on. (just mentioning those) Also the malfunction lamp (MIL) and EPC light up when the ignition is turned on.

There is the required amount/ and correct brand of; coolant, oil, gas, and other things. I've tried jumping the battery, and that didn't work. Could it be the alternator? If not, then what is the possible problem?

Found out the a6 was on recall for defect in sun roof design clogging up n water collection g below windshield under hood n running back inside the cab under the carpet flooding without you knowing. Car still only cranks over n won't start

Just replaced the fuel pump Mechanic thought it was my problem.But now the car turns over but still won't start and now the EPC light is on.My friend who is a mechanic I guess says it doesn't seem to be getting gas to the engine but there is fuel in the lines. He's lost and I don't know what to look at next.Signal mom please help me.

JUST bought 99 A6 quattro, non turbo, with 180k miles, was in good shape except the solid ABS light, blinking brake light and the typical oil leaks. Here's my question..Had a recent snow/ice storm, slid into a guard rail almost head on, roughly 15mph..hit passenger side front bumper..broke neck off top right of radiator....ok, so radiator is $130..no biggie...labor another story, and is it really a simple swap of radiator, or do you have to do a bunch of other stuff, with AC compressor and such to pit a New one in? Im asking, because I'm a single mom, this is my first German vehicle...other than flipping a porsche 944....how much can I expect this to cost to repair? Im considering selling as a mechanic special, but don't want to get lowballed because I'm female and presumably incompetent about cars,though Im not...any suggestions would be greatly appreciated. I just need a running vehicle that wont be a money pit..happy to send photos of damage... also, other than no ABS,which of course proved detrimental in this situation...is it bad to drive it with the ABS module needing repairs?

Thanks in Advance!!

My audi has 141000 miles. The engine light came on and scanned as torque converter failure. That was 30K miles ago and two trips out west, including a tour of the mountains. The car runs and shifts flawlessly. I have a hard time believing it needs this repair. I clear the code and it returns within 20 miles or so....could the sensor be bad? Why does it continue to run and shift so well? I would love to get the light to stay off with out spending $6K on a trans and torque R&R it doesn't not seem to need. Am I just blessed to be driving it still? Or could this be a false code from a bad sensor?
Thanks for your help.

It won't go into forward gears but will go in reverse. The prnd is red as well. Is my transmission bad? The person i bought it from said water got into the transmission take sensor..

Is this why my check oil light is on?

Lights come on together at slow speed, no braking, no slipping. ABS module pump continues to run, after turning engine off. Continues to run and will run battery down, unless disconnected. After some time, reconnect and it has stopped and lights clear. Happened twice yesterday. Replaced ABS module, ouch, still has problem.

When driving and take sharp turn rear drivers side sways

Car won't go into drive