Car Q&A Community

Answered Questions

Ask a Question
View:RecentAnsweredUnanswered
Our truck died at a stoplight, and was unable to restart. We have replaced the battery, and starter, checked the alternator, and tried resetting. The truck just clicks when we try to start it. This makes the third tim...
the car drives fine but due to this coolant leak after the car is run for awhile it over heats coolant leaks to the floor of my pass. side floor board and when this occurs the car runs hot and my oil light has started...
My belt is starting to unravel. I have looked at it and cannot figure how to relax the belt for replacement. Is there an adjustable take up or some roller that can be freed to relax the belt.
The rear passenger seat is locked in the down position and I cant get the seating part to unlock, the back rest will lift up and lay flat, but the whole seat wont reposition. Is there a trick to removing the whole sea...
We purchased a used ML430 and ever since we bought it the SRS and Airbag Off lights have been on. Sometimes they will go out for 30 or 50 miles but then come back on. The seller assured me she had taken it to a Merc T...
Happens when the vehicle is being driven and continues to make noises since it first started, a couple of weeks ago.
after dealer service after continuous driving +25 miles reseting does not cure reinstall of software has worked previously
how do i change the clutch slave cylinder on my car
unable to find fuse box, owners manual lost
We seem to be having continual problems with the information display panel lights, the LED's dont seem to work half the time, very dim or nothing at all especially when its a hot day. Also the ABS light comes on after...
Car was just detailed inside and out...when I picked up the car the A/C Rest light was on and when I pressed it again the light just blinked. There is no A/C and I had great A/C the day before.
all eletrical working motor will not turn over what is problem
will not turn motor over lights evrytthing working
I installed a heater blower motor in my 300sl. And the motor only blows on the lower speed. When i first installed it the motor blew on all speeds. After five minutes in only blows on the first speed..
turns over wont start need to try to eliminate the crankshaft sensor...ingnition switch like i said before battery good starter good... the crankshaft sensor did not test okay the light did not light up...whats next? ...