I'm smelling antifreeze everytime we drive it. Please HELP!!!!!!

the fuse blows after a couple of days driving. if i replace and try right away it keeps blowing if i let car sit a few days and change it it starts right up

OK, I have called my mechanic but he hasn't called me back yet and am concerned...
When I depress the brake pedal everything is ok until I get to the "bottom" of the pedal, you know, keep pushing down, then poof, it starts making wonky noises. It is a low grumbly noise. Almost grinding but not quite. The noise is coming from the back of the car and almost sounds like the trunk.
To make do, I am downshifting and using the brakes as little as possible.
Any thoughts?
Thank you,

It was steaming making abound steaming on the right side,I noticed where the top radiator hose is going to thermostat on the housing of the thermostat it had a bolt missing. I'm thinking it's the thermostat but not sure..after I put water in radiator again it was at norm temp then did it again.. Same thing when I stopes no water?please help thanks.

i have a gas leak it leaks out just from sitting and especially when i start it up.

The loud sound/roar continues while driving.No issues with driving.It sounds like it's coming from the back.
Happens everytime you turn on my car and drivie it.

it's located on the center console

start" What is that button for and what does it do?

The car and rpm goes up really high like some is stepping on the gas pedal.

I want to add a red LED light strip on the outer edge of each door...the aspect exposed when the door is open…where the latch is located. I want these red lights to illuminate with the interior lights when a door is opened...to make open doors highly visible to street bicyclists at night. Easy to wire if I can tap into the switch or activator wiring but where is the switch? No visible spring-loaded button switch anywhere on the door frame. So, where is the switch?

I used to have a 2001 420E 4Matic, sold it. two years later I bought a 2001 MB E320 4 matic, key fob from previous MB 420 is better than E320. How do I change the one fe=rom the 420 to work in the 320?

No response sometimes from stop with gas totally depressed, then takes off at high engine speed. Very dangerous when trying to enter traffic, no engine error code present.


I have a Mitsubishi Montero Sport XLS 4x2 3.0L V6 that will not start it will soon be 1 year.
It all started when I had to change a timing belt bitter 90000 km on the odometer. The engineer any reassembled., And I restarted the car without problems. the next day, wanting to go shopping, the engine refuses to walk. when I put the key in START, the engine turns over fine but no spark to the spark plugs. although I had to change the spark plug, ignition module and the 3 ignition coils, the problem persists. When I bring in a specialist to diagnose the Mitsubishi mut3, failure came from the crankshaft. Ultimately, the timing belt was loose. In light of that, I even changed the position sensor camshaft and crankshaft, then we flunk the engine according to the markings. Upon restart, same thing, no sparks on the spark plug. Following the advice of an electrician, I ordered and changed the ECU MR560347, but LIKE! !
It should also be noted that the ignition module begins to heat gradually when I start the engine just to "ON"; is it normal?

I do not know what to do and I am asking for help.
Help if you like it! my car has not rolled much!

I can hardly get to the wires to remove them. I have read to put it on a lift but I have no access to a lift.

HELP, it's driving me nuts!