Car Problem Reports

Newest Car Problem Reports

Report A Problem

Please can some one help me my car has the ima and engine light and I don't kno. How to fix it

When it gets up enough speed for second gear it revs up and eventually catches and resumes normally.

I just replaced both my calipers and pads last week. At 1st the brakes felt loose but throughout the week they tighten up. Today they were find and I went to the store and as I was parking I lost my brakes and hit a parked cars. What is wrong with my brakes?

So my 1997 Infiniti j30 started sounding like a diesel truck on the freeway. Right as I got off my car completely died. Not sure what the problem is. Need to get it fixed ASAP as this is my only form of transportation. Anyone please help out and give me some problems that could have caused this and solutions to fix this issue.

How to disconnect current headlamp - problem with wheel side connection

Was driving and car died, no engine light or codes to detect. Changed fuel pump and crank shaft positioning sensor

took my car in for new brakes and After that I continue to her noise breaks started to tighten. Found out the booster was bad.

When driving for an hour or so on the highway the Jeep engine stalls out and cannot be started for a bit. Repair are without a clue.

I don't know exactly either water or oil leak, maybe one or maybe both. I just bought the car 3- weeks, trying to tell the dealer, got nothing from them. I want to get diagnose and I will make decision after nothing to loose anyway if I return the car back, I will talk to the back first to unwind the car I will loose my headache .

Still don't know what is wrong. I will take to diagnosis . Talked to dealer didn't go any where. I just bought 3 weeks ago.

my power windows won't work at all they worked some what and then someone hooked a stereo and speakers up in my car and now nothing. I checked the fuses that are under power window and their fine. someone please help me a lot of rains coming and one won't roll up lol

When i first got my 08 G6 back in 2010 it started messing up the first couple months. I took it in and they took out the automatic start and the unlock/lock key fob. The problems its been having are as follows; Gauges error out while driving down the road, Steering will lock up and the car feels like its shifting gears. Also it does this randomly but it happens most right after i pump gas and it takes 2 times to start the car after pumping. Ev...

I have intermittent problems with my turn signal and hazard lights. They work sometimes, then don't even in the "blinker on" positions. What is happening is that the heater unit changes from defrost to general upper blower setting....when this happens, the turn signal stops working. It's getting worse.

not fixed, just wondering if changing the catalytic converter will fix the problem of decreased power upon acceleration

The dome lights in the back and front stay on even when I'm driving. All the doors are closed so I don't understand.

While driving down the freeway between 60 - 70mph, car just quits, completely dead. No sputtering, no coughing..NO WARNING!
1st time, after less than a minute, it started back up, with no further problems.
2nd time was the following day. Same thing, on the freeway, doing approx 65, but this time I hadn't traveled as far, but the car died and this time it didn't start, right up. The starter is strong and is turning over, yet it doesnt engag...

Engine has severe vibration when in drive, at a stop, and cold. Take the vehicle out of gear, accelerate, or let it warm up and the problem goes away

the hinge on the rear window came unglued

I have 2 Subaru Legacy's. Both have given me the same overheating problem at various times. This mimics all the symptoms of a head gasket leak. But the solution is ridiculously simple. Air gets trapped in the heater element, which sits under the dashboard and is higher than the radiator so that the air does not bleed out. There is no independent thermostat bypass in a Subaru. The hot water flowing through the heater element re-joins the main c...

the lights are on all the time. unplug battery

back up camera is sideways

After driving at highway speeds for about two hours, the check engine light comes on. The light will go off after driving at normal speeds -- city driving -- after a day. I've had the dealer assess and they say they can find no problems.

My car runs good, I have had no transmission issues ever and suddenly one day as I braked to let the car in front of me turn and continued to accelerate, it reved up but went no where.. Now it seems as if it is in neutral all the time.. It came out of nowhere and I am hoping it is a censor? Usually when this car breaks it is a censor?? Any help here??

I'm having some clonking noise coming from underneath my truck when I turn and a whining noise coming from my engine when starting it up and a good long while after car has been warmed up

The sliding door on the drivers side has stopped working. It is shut and the lock is stuck. No motor noise either. There are 2 screws on the pannel to remove to take a look but they are on the inside of the door and the door is shut so I can't get at it.
Any suggestions as to what may cause this to not work?

I been having a water leak in my honda accord it started on the floor in the back behind the passenger then behind the driver seat now it's all over

And a clicking noise when turning replace both lower sway bar links inter tie rod and wheel baring and still making the knocking and clicking noise

my old cat gave out and I didn't have any power going up hill and nothing. So we rimmed out the cat which is the honey combs inside and I sounded better but there no oxygen being sensed so my check engine light is on. Some and my friend decided to put on a new cat and new exhaust manifolds. It was successful but the next day I woke up to go to school I didn't drive not even a 1/4 mile on my way and my truck had no power. I pulled over and look...

3 batteries replaced in last 6mos. finally found dealer in Denver that correctly dx this big problem. THE INSTRUMENT DISPLAY CLUSTER WOULD NOT SHUT OFF. WAS ABOUT $500 TO DIAGNOSE AND REPLACE. TAHOE CRANKS EVERYTIME NOW. GOING ON 300K MILES SAME ENGINE AND TRANSMISSION

My Toyota´s Land Cruiser (2012) air conditioning stopped working because of a bad installation of the winch rope (and I had never used the winch rope). I had the same problem with my Toyota Land Cruiser 2008 (Toyota fixed it no charge), and at that time I thought it was a random problem, but it wasn't because the same is happening again.
I wanted to know if someone has the same problem.
Visit my video (unfortunately is in spanish.. but I'm t...