2005 Ford Expedition Q&A

2005 Ford Expedition Question: problem oil pump

I have a 2005 ford Expedition I was driving and the oil gauge started moving from high to low quickly and with engine light on. . The engine starts now, but again loses oil pressure . Is this a problem oil pump (no oil spilling out). Thanks -
Answer 1
If your vehicle's oil pressure light is on- do NOT start it anymore. Engine damage may result. The check engine light will come on when the varible cam timing system loses oil pressure not allowing full function of the VCT. Is the oil level clean and full? These engines seem to consume oil and if the oil change intervals are extended, we see oil system concerns. A manaul oil pressure test must be performed to determine the extent of damage. -
Related Items:
I need to know steps to replace the oil pump
I have a 2002 XLT 46 Expedition. I was driving in cold weather on 1/2/09 and have 115K on the engine. I was at 65MPH and the oil gauge started moving from high to low quickly and then the engine sh...
The camshaft sensor, crankshaft sensor and 4 coil-packs were replaced on Saturday. Truck was running smooth for about 2 miles. Check engine light came on and the low oil pressure warning came on. P...
2006 expedition 5.4 lt engine 150K miles. experienceing loss of oil pressure during moderate acceleration, engine gets very noisy like engine running without oil.(oil is full & clean) Sometimes oil...
dropped off vehicle to shop and engine running fine on all 8 cylinders, they repaired what was supposed to be done and when i went to pick up, engine only running on 6 cylinders. they said it would...