Close

2004 Pontiac Grand Am Questions

Get answers to questions about your 2004 Pontiac Grand Am at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
115
questions

I had to replace my ignition cylinder because it locked up and would not turn. I disconnected the negative cable from the battery, removed and replaced the ignition with a new one. When I went to connect the battery back up, the starter engages immediately even when there is no key in the ignition.
Ive read somewhere that it could be the solenoid, is this accurate and if so, is there some way to troubleshoot it before I spend another $80?

my car will go into reverse but when u put t in drive or low 1,2,3 it acts like its in neutral

I want to replace sensor and its in an area that is not easy to get to with certain tools.

Won't go more then25 miles a hour

It is behind the air bag I want to say

After draining the car started and then when added coolant it stopped again. Water in 6,4,3 which is weird. gonna pull intake and perhaps head gaskets. Just dont understand why the leaks are on two different heads.

The A/C unit does not work. I tried to add refig. but can't get the compressor to Engage.

went thru a lot of water and car stalled. I have replace the starter car will not start

IS A PONTIAC GRAND AM 2004 AND CHANGE THE RADIATOR COOLANT CHANGE AND KNOCK SENSOR AND PERSIST TERMOSTSTO OVERHEATING PLEASE ADVISE ME WHAT ELSE TO DO

the engine overheats and the fan will not start

car stars fine but when I shut the car down I I open the door and leave the car the radio still plays,the batterie and oil pressure light stays on and iam scared to drain the battery so I unplug the negative cable off the battery.the security light doesn't always appear but car starts and runs fine.there is a clicking annoying sound with the flashers and the flashers work when it wants too.

is it normal when your key is out of the ignition and you get out of the car and you have a security and battery and some sort of motor signals in the dash by the speedometer.i have to disconnect the negative cable on the battery so I don't drain the battery.... please help me find the solution thank you

it is in the front of the car its not coming from the pan...its coming either the starter or right above it its leaking pretty bad

It seems to stop making the noise after going a few yards almost like it has warmed up or lubricated itself. Any ideas what to check and how much it may cost me?