38
questions

JUST replace a fuel pump.so #1,battery is dead.an have been for 2weeks. Got a charge,
Turn the key engine turn no gas is pumping,did it a couple of times.wen I turn the key I don't hear the fuel pump turning on.
#1,battery don't stay charged.#2,might have an electric problem? I need help.

I've had three cans of freon however you spell it put in and nothing checked fuses they are good went to woods battery they unplugged my negative on battery said it should reset I do not know what's wrong please help with answers thank you

I have replaced the fuel filter,crank shaft sensor,coil pk, the cycl and/key. And the car will not start. it cranks but that's it. And the security light is on!!!! Please help this Greek Lady out!!!!

I have replaced the fuel filter,crank shaft sensor,coil pk, the cycl and/key. And the car will not start. it cranks but that's it. And the security light is on!!!! Please help this Greek Lady out!!!!

ir will take gas then it won't over and over again until I let it rest and then it's fine again. Could this b a cooling sensor or the fuel pump?? Please help

It runs just fine until u drive it for about an hr than with gas pedal pushed down it will take gas than it won't. Could this b the fuel pump

My 1992 Bonneville SE is stalling after 10 minutes or less then won't restart for about an hour. Initially it wouldn't put up a trouble code in the computer, but finally kept it running long enough to set up 2 codes. 31 and 41. The PNP switch has been bad ever since I owned the car, but the 41 code suggests the camshaft sensor circuit or cylinder select in the ECM. I am assuming it is the camshaft sensor since in the code reader manual, a 31 can also refer to the camshaft sensor circuit. By pulling the gear shift down to drive and increasing the RPMs, I got the car to keep running past the sputtering and it continued to run fine afterward until shut down and the check engine light appeared and revealed the codes. The engine would not restart until it had cooled down for about an hour. When it does this, I have checked and noted that there is no spark from any of the ignition coils until it has cooled. I have cooled the ignition coils with alcohol, but still they do not set off a spark until the engine itself has cooled. Any one else experience a problem similar to this and if so, what causes it. Engine runs great when running and has always been dependable until just 2 weeks ago when this problem surfaced.

sometimes the gauges work just fine but most of the time they will not come on at all. The info center does not work when the gauges do not work. It doesn't seem to have anything to do with temp. My mechanic is pulling his hair out trying to fix this. It has done this in the past but always went away. This time it is more often than not.

cam timing is off.

1992 Pontiac Bonn. have always driven in gear OD. stills shifts nice.! recently serviced feeling something at my feet and hear (with windows open) knocks/pings. no hesitation. no jerkin. is OD gear going out... that possible? or the whole tranny. can just one gear be fixed


I get a popping noise turning corners but seems to be happening more often