1997 Plymouth Grand Voyager Questions

Answered 1997 Plymouth Grand Voyager Questions

Ask a Question
View:RecentAnsweredUnanswered
turn ignition, no clicks, nothing at all. replaced battery and cables. still nothing. lights and interior and dash lights come on, fully charged battery. Just happened suddenly, drove and started fine day before, in m...
R could it be crankshaft sensor r something else I'm stumped i was driving my kids to school and it was running fine then it just cut off on me so I'm totally lost on what it could be so plz help me
The wiper arms do not always swing, sometimes they stop in the middle of the windshield.
my vehicle donot change gears while driving my speed ometer not working when i stop my vehicle cuts off the rpms drop
My dashboard gauges intermittently quit;but usually return,after a day or so.I'm hoping it's just a loose connection.
My van had problems twice starting, wouldn't start just clicked, but got it started after a few minutes. Then I tried to start it one morning and it just clicked, I hear the fuel pump and I have power to windows, rad...
So I put my car in reverse and it wount move then I put the car in neutral and it moves forward I added transmission fluid but nothing has changed please help me don't know what else it may be
When you turn on the key there is a clicking sound coming from under the glovebox. Is there a starter relay there ??? Used the van a week ago and it was fine,
how do i remove the cylinder head from my grand voyager and reinstall a new one?
my van gets hot when i turn on ac done pulled thermastat run good with out air on turn on ac loose a lot of power
My van 1997 Plymouth Grand Voyager SE 3.3L, died while driving, speedometer go down suddenly and motor died. I check signals for injectors, crank sensor, Cam sensor, pump gas, and all ok, I replaced the computer (PCM)...
My van 1997 Plymouth Grand Voyager SE 3.3L, died while driving, speedometer go down suddenly and motor died. I check signals for injectors, crank sensor, Cam sensor, pump gas, and all ok, I replaced the computer (PCM)...