I put a new fuel filter and pump on it, and a new coil pack. It is still just shutting off while driving no warning no nothing. When I spray starting fluid in the air filter it stays running? What could possibly be wrong? Im leaning on something with the fuel but at a loss?

This van has so many electrical problems .i looked at the fuse panel and the circuit board is coming apart.im having problems finding one.

Started van it started up,i started to drive & it stalled & wouldnt start back up then my battery needed charged so i had it charged full charge on battery,i tried to start it & it wouldent start, it turns over it just wont start,i noticed my cam censor needed replaced,i am about to go put it in now,when i turned the key i seen that the lights were blinking on dash where my heater& air conditioner temperature control is,

What causes a Plymouth Grand voyager 3.3 L Distributor less Ignition Systems to randomly not have spark from the second coil even though a primary and secondary resistance test shows all 3 coils to be good?

Cylinders number 1 & 4 has no power at harness going to coil pack during cranking. How do i trace these wires back to the computer are they color coded? If so what color wire or wires do I need to find to get this van started.

96 grand voyager se, 3.3- seems all this happened at once: no turn signals, no cabin blower fans front or rear, no rear wiper, air bag and abs alert lights on. Fuses seem ok & harness connectors on steering column ok.

It happens about 20 minutes after it warms up.