1997 Oldsmobile Regency Questions

Answered 1997 Oldsmobile Regency Questions

Ask a Question
View:RecentAnsweredUnanswered
car flutters and does not run smoothly especially when driving slow or idling...would it be the oxygen sensor?
Can you tell me why this happens?
I have car for several months, ran a little hot(my opinion) not good gas mileage. Began to run rough. Stopped car. When started then began to overheat stopped car found loose connection that plugged into back of radi...
I found out the popping noise I have been hearing is the engine cradles both sides front and back need replaced.Frame seems fine, 2 in front and 4 in back.The 2 the farthest back are completely gone.No bushing in them...
A couple of days ago I noticed that my interior lights were on during a 20 min drive home and I just figured that i hadn't shut all of the doors properly. When I got home I checked all of the doors (this wasn't the pr...
no air ride pump running
The fuel gauge on my 97 Regency does not read properly. Sometimes it will read a full tank and other times it will be empty when I know it has a full tank. Is this a common problem and if so how would i go about fixin...
After my car is warm and i turn it off and start it again it doesnt wanna start, kind of sputter starts like it might die. Also when i drive it, it sounds like a farting noise coming out by the intake manifold. What s...
Transmission shifts funny from 35-55 if under a slight load. Shifts fine if not under a load and seems to shift ok too if I'm rapidly gaining speed opposed to gradual speed gain.It would jump back and forth when tryin...
Transmission shifts funny from 35-55 if under a slight load. Shifts fine if not under a load and seems to shift ok too if I'm rapidly gaining speed opposed to gradual speed gain.It would jump back and forth when tryin...
A/C and heater both blow fine upper and lower but neither will blow thru bi-level. I checked under the hood under the black plastic box by the firewll. There was a split tube with one small vacuum line disconnected....
I'm not sure if it's slipping or just plain not shifting properly. Started about a month ago at about 45-55mph. It would jump back and forth when trying to upshift, if I tried to gain speed it evenually shifts up ok ...
A/C and heater both blow fine upper and lower but neither will blow thru bi-level. Is this a fuse, vacuum hose or what? If it's a hose where would it be and would it be disconnected or something else? Would it be u...
What else would be the most likely cause of the problem, a fuse or the relay? If it's the relay is there one for each side or just one for both? Where is(are) is located? Thanks Very Much Bill
Car quit just driving down road.Starter just clicked. Pulled starter all good, but Crankshaft was locked up. Reversed crank W/Socket & Breaker Bar and it turned over w/starter back in, but won't fire. After turning ov...