1994 Oldsmobile Cutlass Supreme Questions

Answered 1994 Oldsmobile Cutlass Supreme Questions

Ask a Question
View:RecentAnsweredUnanswered
For the last few months I'am having this issue,Took it to Firestone,but they don't do that type of repair.But said it's a short and I have take it to the dealer?????What type of test will a person do to check the issu...
Every one has a OB2,but by me having a 1994 Oldsmobile Cutlass Supereme S,no one can scan for codes,needs someone to scan for ABS codes.Had it checked 2yrs ago,and seems like it had a TSB,on my car,saying that a wire ...
had sub frame dropped,1 tierod disconnected,turned steering wheel,was a snap, . what do I do ?
Hey guys my when I turn the left signal on on my 94 cutlass the brake lights go out, it only happens with the left side and I already replaced the combination set itch, has anyone encountered this before?
changed brake light switch replaced bulbs still no lights every once in a while they work
Gages stopped working.
Can a NEW starter be bad,and should I be changed again replacing the 2nd one.Do U think that it was a rebuilt one the frist time?Thanks
Basically I bleed the brakes in the fashion described in my repair manual, I have good firm pedal but it seems that all the stop powering is on the bottom of it which scares people. I did just have the brake master cy...
The snow that was had frozen my doors.I finally gotton the passager side opened,so when kept hit it,I've gotton it opened,however,the latch has alot of play,and now I have to go to the passager side to get in,but I ca...
Eversince my engine was put in,my car willn't start @ times,it's getting current from the battery,butwhen I turn the key,NOTHINGit's not the starter,battery.I'am going to do an test on it.What does it sounds like to Y...
The c/c sometimes willn't engaged.It will work for a bit,then it willn't.I've tried the fuses,it's ok.I've cut it off when I cut the car off,acted the same after it's turned the car back on.What else could it been?Is ...
They said that both hoses were cold and he also said that my water pump was bad,but in the end all it needed was a fan motor,which was the same one from 1994 when the car was made;AC DELCO,now it running right.I'am ve...
hecked fuses,ok,checked coolet,ok.When I'am driving @ high speeds;25-55mph,I can really feel it,but ideling,not that much,but feeling in the vents.What woulg cause that.It is trying to work it self out,clogged heater ...