2002 Ford Expedition Q&A

2002 Ford Expedition Question: oil pump

I have a 2002 XLT 46 Expedition. I was driving in cold weather on 1/2/09 and have 115K on the engine. I was at 65MPH and the oil gauge started moving from high to low quickly and then the engine shut down with engine light on. I have changed the battery, the cable wire and posts. The engine starts now, but again loses oil pressure after 10 mins. Is this a sending problem (electronic), oil pump go out (no oil spilling out). Any input would be appreciated. Thanks -
Answer 1
There's a oil pressure sending unit located behind the oil filter cost is about 10 to 20 dollars -
Comment 1
Thanks for your response! -
Comment 2
is there a way to test unit -
Related Items:
I need to know steps to replace the oil pump
...ith engine light on. . The engine starts now, but again loses oil pressure . Is this a problem oil pump (no oil spilling out). Thanks
The camshaft sensor, crankshaft sensor and 4 coil-packs were replaced on Saturday. Truck was running smooth for about 2 miles. Check engine light came on and the low oil pressure warning came on. P...
2006 expedition 5.4 lt engine 150K miles. experienceing loss of oil pressure during moderate acceleration, engine gets very noisy like engine running without oil.(oil is full & clean) Sometimes oil...
dropped off vehicle to shop and engine running fine on all 8 cylinders, they repaired what was supposed to be done and when i went to pick up, engine only running on 6 cylinders. they said it would...