» » »

Chevrolet Q&A

Ask Your Question

1991 Chevrolet S10 Blazer Question: oil leak

 

Question

vikinglords, Midlothian, VA, April 30, 2009, 12:27
 Rookie

my answer the pice is the oil pump i think it is right next to the oil pan an two tubes coming out of it going up to the oil filter on the fender wall it is leaking from the two tubs coming from the pump next to the pan what can i do to fix it or how hard is it to change it my self i never done it before

1 Answer
Flag This
  • Answer #1

    May 01, 2009, 09:45
     Master

    You will need to look at the oil hoses and see if you think you can handle the job. The lines have a single bolt at each end and whatever brackets to secure them along the way. Have a look and see if you have the tools you need to access the mounting bolts. The 4WD Blazers and be pretty tight and access can be somewhat limited.

    Flag This
  • Reply

    Visitor, September 13, 2010, 07:40

    I am having the same problem with mine. It only leaks when the blazer is running. Is there a seal that needs to be replaced and do I have to drain the oil? Could it really be as easy as a seal? I have the tools to do this. It has nothing to do with the hoses. It is coming from the base of what I think is the oil pump. It is round, metal in color, with the top having a half moon like shape. The part has 10172752, CAV 6, and Pemco written on it.

    Flag This
  • Reply

    Visitor, May 20, 2011, 19:33

    I have the same problem with CAV 2 10172752 Pemco, we solve it?

    Reply
    Flag This