» » »

Toyota Q&A

Ask Your Question

2000 Toyota 4Runner Question: Noise ...........Please, Help

 

Question

pelusa, 3.4L V6, Renton, WA, January 17, 2009, 10:54
 Rookie

When I turn on the radio the antenna motor makes a noise for about 30 seconds, how can I repair it?

1 Answer
Flag This
  • Answer #1

    patrick mannion from Greg Solow's Engine Room, January 17, 2009, 13:45
    Profile_thumbnail
     Master

    The Toyota radio mast has a chrome colored ring around the base of the antenna mast (there is a special tool to remove this ring to avoid scratching the the bodywork but I have loosened the locking ring with two screw drivers and a lot of care). With the locking ring removed get someone to turn on the radio while you pull upward on the antenna mast/cable. After removing the old antenna mast and cable compare the length of the "new cable and mast" with what you have with drawn from the motor. If the new assembly is longer a piece of the old cable is still stuck in the motor assemble and it must be removed and dissembled to remove the entire cable or you will never get the antenna to fully retract. If you are lucky enough to have gotten all the cable out to get the new cable to retract. Feed the cable into the motor until you feel it engage the gear in the motor, get a friend to turn off the radio and the cable will retract. If it doesn't fully retract, turn the radio on, let the cable and mast fully extend wait a few seconds and then retry turning of the radio. Probably half the times I end up having to take the assembly apart to get out pieces of broken cable, not a job I think you would want to tackle. To gain access to remove the motor.
    We are trying to build something very special here at Repairpal. It would help us and add great value to people in your community if you could take a moment to rate your experience with a dealership or repair shop in your area on our website.

    Reply
    Flag This