no power to anything on 1998 Ford Escort

car was still running set car up for 6 months because of knocking sound have decided to try and get it fixed and now when i put new battery back in no power to anything and battery cables ends have also been cleaned will surely appreciate any answer that may help solve this problem.

by in Hammond, LA on May 14, 2011
1 answer 1 comment
ANSWER by on May 14, 2011
Is the battery installed with correct polarity? Have you a volt meter? Check voltage across the battery it should be 12.6 volts. Leave the black lead of the voltmeter on the battery negative terminal and see if you have power at the alternator and fuse links/fuses starter motor when you move the red lead of the voltmeter around. Try jump starting the car from another car and see if it will start. If the battery has sat for several months perhaps the battery has sulphated and died.
COMMENT by on May 14, 2011
BATTERY IS NEW JUST NOT GETTING ANY POWER WHEN I HOOK IT UP NOTHING COMES ON AND DID TRY TO JUMP START NOTHING STILL DOING ANYTHING
Related Items:
CAR WAS RUNNING WHEN I SAT IT UP ABOUT 6 MONTHS AGO HAVE DECIDED TO FIX IT AND NOW WHEN I INSTALL A NEW BATTERY CANNOT GET POWER TO ANYTHING AND YES HAD BATTERY CHECK BEFORE PURCHASED THEREFORE ELI...
fuzes all checked only issue is a wire that looks like it had plugs on it, thats directly under steering column, thats black, black/green stripe, heavy gauge, no where visible to plug it into...
There are reports of failures of the CCRM or Constant Control Relay Module.  The CCRM has relays and switches inside that control or provide power to the engine cooling fan, AC clutch (to enga...
Checked spark using tester at plug good spark Checked for broken timing belt- cranked engine over saw valve springs operating Sprayed starting fluid before throttle body, didn't attempt to start ...