» » »

Mazda Q&A

Ask Your Question

2006 Mazda B4000 Question: No informationb displayed on Instrument panel

 

Question

9Fingers, Oak Harbor, WA, October 12, 2011, 19:55
 Rookie

Recently replaced the battery. Restored the Idle Info and infor laid out in owners manula. However I do not have any Speedo, Tach, Temp, or fuel gauge info. Everything Else apears to be working. Lights Radio ect. Just no status information on the cluster worked fine till the battery was charged after discharging.

1 Answer
Flag This
  • Answer #1

    patrick mannion from Greg Solow's Engine Room, October 12, 2011, 20:04
    Profile_thumbnail
     Master

    I can only think a fuse or fuse link has blown/experienced voltage surge. Check your owner's manual for fuse application. Check here http://repairpal.com/automobile-owners-manuals-online or try this link you may be able to down load a free copy of the owner's manual for your vehicle http://www.autousermanual.com/
    You may need a good volt meter and wiring diagram and start tracing circuits. There is a company that independent auto repair shops get their information from, this same information is available inexpensively for people that work on their own cars.. The information is year make and model specific, covering repair procedures, torque specifications, fluid capacities and specifications, service bulletins, component locations, wiring diagrams ect.... Alldata is very easy to navigate http://bit.ly/AllData_Repair_Manuals_Online

    Flag This
  • Reply

    9Fingers, October 12, 2011, 20:46
     Rookie

    I checked all the fuses they are all could nothing has been done to the truck it was not driven for a while and the battery went dead and was charged. I also noticed that when I drove it that seatbelt warning doe not com on neither do the $X$ warning lights to let you know you are in four Wheel drive. Does Mazada have any of their electronics route through the radio simalar to GM Products. The truck had an after Factory Radio when I bought however I have been driving it for about three years and no issuses so I am stumped.

    Reply
    Flag This