1999 Ford Explorer Q&A

1999 Ford Explorer Question: no heat when warming up in driveway only..

I have no problem any other time but, I can leave my explorer in the drive running for a hafe houre and its blowing cold air. But, when I start down the steet it has heat all the time until left off for an hour or so then same thing what the ----!!! -
Answer 1
check your coolant level first. see if the car heats up by the guage to see if the t stat is working. other than that, it may be a clooged heater core which will have to either be flushed out or replaced. Roy -
Comment 1
Just replaced the thermostat because the gage was always cold. Now, its half way and still now heat, till I'm moving once I'm moving it works, when I'm parked or at a light, or when I turn it off for a short while. Just after sitting for an hour or so in the cold. Thank you I haven't checked the levels I will do when wife gets home Thanks again.!! -
Answer 2
same thing happened with me the only thing you need is a thermostat cause when you drive the aintifreeze will speed threw the motor making it hard to get any heat and the thermostat slows down the prosess allowing heat to get threw the heater -
Comment 1
Just replaced the thermostat because the gage was always cold. Now, its half way and still now heat, till I'm moving once I'm moving it works, when I'm parked or at a light, or when I turn it off for a short while. Just after sitting for an hour or so in the cold. Thanks. -
Comment 2
oh ok my mistake i got it switched around did you flush it out? -