» » »

Chevrolet Q&A

Ask Your Question

2004 Chevrolet Venture Question: No dome lights, windows/locks not working, wipers are out of whack??? Help!

 

Question

stjay, 3.4L V6, Angle Inlet, MN, November 12, 2013, 16:49
 Rookie

Van is running good, this is the first time problem. Checked fuses, all are good.

3 Answers
Flag This
  • Answer #1

    ebans777 November 12, 2013, 17:45
    Profile_thumbnail
     Master

    check or charge your battery first.

    Reply
    Flag This
  • Answer #2

    pushrod November 12, 2013, 19:11
    Profile_thumbnail
     Master

    What kind of work has been done on it recently, around the battery, that messed up the wiper's?? That may be your other problem as well. Until ALL the fuses are tested with a test light then they have not been checked!

    Flag This
  • Reply

    stjay, November 12, 2013, 20:15
     Rookie

    No work done on it before this happened. All fuses were tested.
    Parked it last night and all worked good. Dome light on, windows and locks worked fine, wipers were running normal. Tonight:
    - no dome light, no power for windows/locks
    - wipers going from sides to centre and rest upwards on each side of the windshield when off
    - only one delay option working for wipers. Really weird.
    Before both wipers went side to side when on, and rested at bottom of windshield when off.

    Flag This
  • Reply

    pushrod, November 12, 2013, 21:04
    Profile_thumbnail
     Master

    Over by the battery and under the plastic cowl cover is the wiper park cam, a rather complicated little device that took some engineer at least a mounth to come up with!! That is the problem with your wipers and must be related to the other troubles as well. Have a look around over by the battery and under the plastic cover for anything that looks out of place. Other than that it needs to be looked at by a mechanic.
    just thought, there probably is a youtube video on this!! Check to see.

    Flag This
  • Reply

    stjay, November 12, 2013, 21:24
     Rookie

    Will do. Thx for that, much appreciated!

    Flag This
  • Reply

    pushrod, November 12, 2013, 21:30
    Profile_thumbnail
     Master

    Sure thing, let us know how you make out. All of this has got to be related somehow! I say it will be found around the battery there somewhere as a result of the wiper problem! Obviously you were using the wipers about the time this all happened.

    Reply
    Flag This
  • Answer #3

    G. T. Service Center (3111 Answers) , Stephenville, TX - (254) 638-3236
    ProfessorG November 12, 2013, 20:28
    Profile_thumbnail
     Master

    Sounds like a bad ground to me. But who am I.

    Flag This
  • Reply

    stjay, November 12, 2013, 20:48
     Rookie

    okay, a mechanic I am not! So, can you tell me where this bad ground would be?

    Flag This
  • Reply

    ProfessorG, November 13, 2013, 05:51
    Profile_thumbnail
     Master

    Check your body ground from battery ground cable. The grounds for wiper, dome lights are at the right side of dash and the rest are at the left hand lower 'B' pillar. Check LH kick panel and 'B' pillar is the one where the driver door latch is, (back left of drivers seat).

    Reply
    Flag This