» » »

Mercedes-Benz Q&A

Ask Your Question

1994 Mercedes-Benz SL500 Question: New Battery ..... let go dead.....now won't jump or charge

 

Question

Visitor, Muscle Shoals, AL, May 12, 2010, 13:56

I put new battery in 6 mths ago. Car was not driven for3 months during which time battery went dead. Now battery won't jump start or charge. What could cause this and/or fix this?

2 Answers
Flag This
  • Answer #1

    May 12, 2010, 14:15
     Master

    Bring the battery back to where you purchased it from as they usually have a pro-rated warranty and they can test it and give you a new one

    Reply
    Flag This
  • Medium-star Best Answer
    May 16, 2013, 15:08
     Rookie

    I have a 2003 SL 500 and this is a real problem! Firsty, there are two batteries in this stupid car. Secondly, there is a service campaign bulletin, which I guess is short of a recall, which states that there is an alternator problem, and the regulator may need to be replaced. "Approximately 279,948 vehicles are affected." The battery doesn't sufficiently charge off the alternator and the convenience systems (heated seats, etc) may be shut off due to a resulting under voltage condition. Take it to your dealer. The service campaign reference number is: 2005070017, and the date of issue of the bulletin is April 6, 2006.

    Flag This
  • Reply

    videobroker, December 09, 2013, 07:11
     Rookie

    The battery doesn't charge the alternator It's the other way around. I suspect you need to change your alternator. Also have your battery tested at Autozone. A bad alternator will cause all sorts of electrical glitches.

    Reply
    Flag This