my vehicle starts and run extremely rough for the first half hour and then fine on 1995 Dodge Dakota

recently had a rebuilt tranny put in. they broke the crank position sensor and put in a new one.

by in Buffalo Valley, TN on November 01, 2012
2 answers 4 comments
ANSWER by on November 01, 2012
where did you purchase crank sensor, if after market suspect it poss bad. the after market ones cause all kinds of issues.
COMMENT by on November 01, 2012
Crank sensor appears to be ok however I noticed the EGR valve tube (steel tube) bolted to the exhaust manifold leaks and I see that one of the bolts is broke off. I cannot stop the leak. Apparently they must have tried taking it off when they swapped out trannies. That much leak be causing my truck to run like crap for the first 20 minutes ?
ANSWER by on November 01, 2012
crank sensor may be improperly installed....
COMMENT by on November 01, 2012
Crank sensor appears to be ok however I noticed the EGR valve tube (steel tube) bolted to the exhaust manifold leaks and I see that one of the bolts is broke off. I cannot stop the leak. Apparently they must have tried taking it off when they swapped out trannies. That much leak be causing my truck to run like crap for the first 20 minutes ?
COMMENT by on November 01, 2012
EGR pipe leaking will NOT cause your car to run rough...The EGR will block any vacuum leak when it is operating correctly...if it is STUCK OPEN, it will run rough all the time except when accelerating.
COMMENT by on November 01, 2012
ok how will i know if it is stuck open