» » »

Infiniti Q&A

Ask Your Question

2004 Infiniti I35 Question: my trans has a whine noise and kicks a bit hard on quick drive offs. HELP!

 

Question

bigdee4u, Orange City, FL, August 26, 2013, 07:08
 Rookie

I changed out the trans oil and still does the same thing..Only if I drive an easy take off the gears are more smooth but still whines all the time.

1 Answer
Flag This
  • Answer #1

    frankie don August 26, 2013, 08:01
     Enthusiast

    If you could obtain a scan,a trouble code could be set in the computer that would point in the right direction; free scans are available at auto parts stores like Advance auto and Auto zone.The whining could be the pump.It may need an adjustment of the bands or it may have a worn part like a bearing or other .A dealership workshop or a reputable transmission shop would diagnose the problem.Usually automatics are not d.i.y. jobs other than changing the fluid.If you replaced the fluid your self check that it was the correct fluid for your make and model because it is very important.A B.G.FLUSH is it good thing for a transmission and it's available at the dealership for $100plus . I had a B.G.flush done on my van twice already and I recommend it .

    Flag This
  • Reply

    ApJazz, March 05, 2014, 05:53
     Rookie

    my transmission when it first drive off it jerks one time but it doesn't does it anymore unless I stop and drive off again but my check engine light come on every now and then but I figure it was motor mounts that cause in a jerk I have change the transmission fluid and filter and it does the same thing

    Flag This
  • Reply

    frankie don, March 06, 2014, 05:12
     Enthusiast

    If the check-engine lights,it's more likely to be an internal trans. problem than an external one.Maybe a solinoid,if the trans.is not slipping,it is probably a solinoid. An intermittent light could mean a loose connection ,a dirty connector problem.I use di-electric grease on all electrical connections........check the electrical connector that goes into the transmission and look for leaks on the trans.,by all means check the engine-mounts and trans. mount is not broken......loss of power and/or thumps when accelerating is a sign of broken mounts........on a rear-wheel drive ,the engine lifts up and falls......on a front-wheel drive the engine may rock ......to determine if the mounts are broken:...set the vehicle on ramps and jack the engine carefully slowly and only a little at a time while looking to see if the mount separates. good luck with it frankie don .

    Reply
    Flag This
Answer Ranks