» » »

Chevrolet Q&A

Ask Your Question

1991 Chevrolet S10 Question: My S-10 is running rough an wont stay running at idle unless foot is on pedal.

 

Question

gladdep, Flintstone, GA, July 16, 2011, 22:38
 Rookie

173,000 miles on it, fuel filter an tuned up at 140,000, stumbles bad when u try to accelerate, no gas smell, just started all of a sudden, put regane fuel system cleaner in it an didnt help, feels like its in fuel system not electronics, feels like its starving for gas, please help.

3 Answers
Flag This
  • Answer #1

    patrick mannion from Greg Solow's Engine Room, July 16, 2011, 22:51
    Profile_thumbnail
     Master

    It could be many things, unfortunately and without experiencing the problem first hand or being able to do some basic diagnostic tests its hard to say. It's best to start with the basics, does the engine have mechanical integrity (good even compression) it needs to be determined if the engine has fuel, ignition or some electronically problem. Could be so many things a vacuum leak, a fuel injector problem, so many things, some diagnostic tests are needed rather than just trying to guess.

    Reply
    Flag This
  • Answer #2

    wiliamss July 17, 2011, 05:47
     Enthusiast

    check for vaccume leaks around top of motor around intake

    Reply
    Flag This
  • Answer #3

    jsg3535 September 30, 2011, 12:13
     Rookie

    Did you ever get a solution to your problem? This sounds almost identical to the problem I am currently having with my 1989 S-10 4.3L V-6 with 177,000 miles on it.

    Reply
    Flag This