» » »

Nissan Q&A

Ask Your Question

2000 Nissan Xterra Question: my exterra will turn over but wont fire off or crank up

 

Question

sixstring3691, Greer, SC, August 06, 2013, 16:32
 Rookie

i have a 2000 xterra problem started a few months ago was going down the road and it started losing power put new fuel filter in yhen pulled injectors checked and cleaned them still wouldnt start check to see if fuel was pumping good flow at fuel rail, replaced distributor this morning it cranked up fine ,ran it for an hour in the yard no problems took it down the road to test drive it went about three miles it cut off on me and wont start back up any ideas on this. getting fuel and fire but it just turns over

2 Answers
Flag This
  • Answer #1

    August 06, 2013, 20:28
    Profile_thumbnail
     Master

    4 or 6 cyl? If V/6, possible timing belt problem but not likely. Either one check to see if distributor has moved from your installed position. Check rotor screw to see if it is still there and tight!! Loose rotor will still spark, but out of time!

    Sure it still has spark?

    Flag This
  • Reply

    sixstring3691, August 07, 2013, 08:37
     Rookie

    6 cyl everything is brand new still has spark coming from all plugs

    Flag This
  • Reply

    pushrod, August 08, 2013, 13:55
    Profile_thumbnail
     Master

    Replace the distributor!!!!!! Yep, REPLACE THE DISTRIBUTOR!!!!!!!!
    It would not start, so you installed ANOTHER dist., now it did start but died. Defective distributor, got to be!

    Flag This
  • Reply

    sixstring3691, August 08, 2013, 19:32
     Rookie

    How do I check to see if its a bad distributor

    Flag This
  • Reply

    pushrod, August 08, 2013, 21:22
    Profile_thumbnail
     Master

    8-16-13 SO HOW IS THIS THING RUNNING NOW

    Reply
    Flag This
  • Answer #2

    August 07, 2013, 02:58
     Master

    did you put a new dist in it or a used one?

    Flag This
  • Reply

    sixstring3691, August 07, 2013, 08:39
     Rookie

    brand new one getting spark from all plugs checked this morning

    Flag This
  • Reply

    pushrod, August 09, 2013, 18:37
    Profile_thumbnail
     Master

    When fixed, how about posting what action it took, so others with a similar problem may benefit.

    Flag This
  • Reply

    sixstring3691, August 09, 2013, 21:42
     Rookie

    Ordered a another new distributor will let you know when it comes in if the last one was the problem

    Flag This
  • Reply

    pwrfinder, August 12, 2013, 13:07
     Rookie

    Same as above. Tried new dist cap and module. Nothin' Was getting spark, now I'm not. Was getting fuel, now I'm not, stupifying garage. They've checked timing belt already, replaced plugs twice, and now I'm out of ideas, other than checking security light with scan tool to see if there are any codes (not that I know what that means, but I read it in a related thread. Will advise after garage checks same.)

    Flag This
  • Reply

    pushrod, August 12, 2013, 21:56
    Profile_thumbnail
     Master

    Ok!

    Reply
    Flag This