» » »

GMC Q&A

Ask Your Question

1995 GMC Jimmy Question: Motor shakes, Low power at start of accel, missing?

 

Question

foxracingman22, Murdock, NE, August 17, 2010, 09:41
Profile_thumbnail
 Enthusiast

I inhearited a 95 gmc jimmy 4.3 vortec. When i first got it i replaced the fuel pressure regulator. It ran fine for a few weeks. Now the motor shakes at idle, and all the codes are showing is my downstream. I replaced the downstream sensor. I took off the cat, and someone had already punched everything out so its empty. Local mechanic whom nobody trusts says he did a compression check and thinks its leaking air/compression between cylinders 4 and 6. I have replaced the spark plugs and wires, but not yet the distributor like i should have. Was told to open my radiator cap and if the coolant is shaking than itd deff be the head. I dont want to be driving it, but i have a few times but just 6 miles overall. Where should i start? what should i do? lost and really need this vehicle. HELP PLZ!

1 Answer
Flag This
  • Answer #1

    Visitor, September 28, 2010, 12:33

    Have someone check the fuel rail. These vortec's are known for plastic fuel lines in the top side of the motor, that tend to get brittle, and will lead to problems like the truck is missing out. this is probably your best bet,

    Flag This
  • Reply

    Visitor, September 29, 2010, 22:30

    Havent tried what you said yet, but i did recently replace the whole distributor, rotor, and cap, regapped my plugs cause they were .020 off. Replaced the coil pack, the cat, and both 1,2/2,3 sensors in the transmission. Not much has changed, except the motor dnt shake as bad. still misfiring, and still no get up and go, and wont shift into 3rd.

    Reply
    Flag This