missing on 1997 Chevrolet 1500 Pickup

eng idles fine under load it breaks up -missies changed fuel filter recenly mechanic put new fuel pump because truck would not start

by in Coram, NY on October 31, 2010
1 answer
ANSWER by on October 31, 2010
You could have ignition system troubles or fuel system problems. You need to get the ignition system checked (sparkplugs, wires, cap and rotor), including spark strength under load. You also need to check the fuel pressure when the engine is cruising and under load, which can be done by safely connecting a mechanical fuel pressure gauge to the test port on the injection system and go for a drive. Use adequate cautions for fuel pressure testing while driving.
Related Items:
engine has a miss at idle but runs fine at higher rpm. I have replaced fuel pump plugs wires cap rotor and fuel regulater can't figure out what is wrong. I had a diagnostic check done and it shows ...
idles fine, takes fuel fine, only misses at constant rpm driving.diagnostic code says ignition misfire,replaced mass air sensor and air temp. sensor
The dust cap on the front pass wheel is missing......is that OK?
missing happens when stopped but does not die, but runs just fine otherwise. I have replaced the EGR valve, o2 sensor, fuel pump/filter, oil sending unit. What else can I try?
The OE pulley is plastic. When I bought a replacement today it was metal. However if you tighten the bolt down the pulley will not spin. I noticed that when I took the old pulley off the bolt was ...

Related Content