missing on 1991 Cadillac DeVille

I just did a tuneup plugs,wires.coil,cap,rotor,control moduel, even changed out dist. It runs ok on the freeway but misses when i'm taking off. It doesn't seem to run as good as it did before tuneup gas mileage is 21 on hwy that to seems more. Idles good when cold but so as warm taking off at lights it misses until I get over 40

by in Reno, NV on May 04, 2011
1 answer 3 comments
ANSWER by on May 04, 2011
sounds like an injector. you have done the basics now it time to get some help as you need to identify the injector, test it and have it replaced. take it to a shop to verify. Roy
COMMENT by on May 04, 2011
I thought it was that i put some cleaner in it and that helped but it still is not right thank you again .
COMMENT by on January 13, 2012
what company for repairs other then dealer can do a "REAL" injector cleaning? I have been told that most places charge $70 to upwards of $120 for that service and you can get same results just using $10 bottle of lucas injector cleaner yourself.
COMMENT by on January 13, 2012
the cost is about 79. this cleaning is not an additive that has little effect on the cleaning process, it is a direct injection into the injector rail and injector that cleans the carbon from the pindle. takes about an hour to perform and is well worth it. Roy
Related Items:
startup when cold doesn't seem to miss, when engine warms ups misses worst. ghanged fuel filter and cleaned throttle body with solution spray. fuel pump pressure 45 lbs.
I have a miss at idle and it hesitates when I start up. Seems like it needs a tune up. How do you change the plugs and wires on a 2002 Cadillac Deville?
Engine misses when trying to increase speed from 50 to 60 mph.
Hello: I have a 1998 Cadillac Deville (base) with a 4.6 engine. The engine is starting to miss intermittently mostly noticed during idling in drive. Have owned for 2.5 years. Has over 130,000 mile...
Found that I'm missing a hose on the vacum purge switch - the hose that runs back to the canister. Any ideas on fish...