» » »

Chevrolet Q&A

Ask Your Question

1996 Chevrolet Camaro Question: Mis-Fire at idle but stops when driving or accelerating.

 

Question

Camaro Freak, Rose Hill, KS, April 30, 2013, 07:04
 Rookie

My 96 z28 from my mechanic said that the engine is mis-firing at idle but when driving or accelerating, the misfire goes away. this is what his computer tells him. he said he doesnt exactly know what is causing it but was offering to fix it for me to the tune of $500 starting off and going up the longer it took ti find the issue and fix it. i have looked up all of the parts to replace on engine for ignition and willing to spend the money to purchase all of it but would like to find out what i should start with.

2 Answers
Flag This
  • Answer #1

    pushrod April 30, 2013, 09:14
    Profile_thumbnail
     Master

    How can he tell you how much before he knows what the problem is? Get another opinion. Low compression or vacuum leak come to mind here.

    Reply
    Flag This
  • Answer #2

    ziptie12 April 30, 2013, 17:43
     Master

    Save the '$500.00to start' and go with wetrys' response. The other possibility that comes to mind for me , is incorrectly gapped or incorrect type of spark plug. If they are not factory plugs and wires on it , try that -can't make it worse unless done wrong.

    Flag This
  • Reply

    Camaro Freak, May 06, 2013, 06:08
     Rookie

    The Spark plugs that are in it are AC Delco Rapid Fire. I dont know if these have anything to do with it? They came in the car when i got it 3 years ago but i have only put 5,000 miles on the car since it is my "toy" or if my wife has a doctors appt to go to and we have to drive seperate vehicles to work.

    Reply
    Flag This