» » »

Mercury Q&A

Ask Your Question

2004 Mercury Monterey Question: Mercury Monterey leak with water coming in.

 

Question

mom4, San Antonio, TX, September 20, 2009, 12:03
 Rookie

I had water coming in the right side sliding door area every time it rained heavy and the streets had standing water. You could hear water sloshing around inside and the carpet all down that side was soaked. They finally figured it out and said they needed to reseal all the body plugs on that side. I was charged for parts. Is there a part needed for doing this? Also do you think I may have permanent damage inside the car? That side under the door looks like it may be starting to rust and the carpet down that side is brown. It took them over 2 years to finally figure this out.

3 Answers
Flag This
  • Answer #1

    Valleyautotech February 11, 2010, 16:03
     Master

    Have you solved this problem, if not please ask your question again or you might find a free repair manual here: http://bit.ly/autozone_repair_info or go to http://bit.ly/alldata_repair_manuals or http://bit.ly/mitchell_repair_manuals_online and get an online repair manual subscription.

    Reply
    Flag This
  • Answer #2

    Visitor, June 06, 2010, 12:29

    I found problem on my own -- water ONLY came into rt rear door track during driving in RAIN. Took off rt rear tire and found wheel well seam sealant had not completely covered front edge of seam, so there was a pin hole that let water in ONLY during rdiving in rain storm, car washes, etc. did not affect. Hope this helps. Other than this, I've had 105k miles of trouble-free driving with the Monterey!

    Flag This
  • Reply

    ctjenks, March 08, 2012, 12:21
    Profile_thumbnail
     Rookie

    have a 2004 monterey van; love it! 4.2 ltr etc etc; had same problem just this year with water in the right hand sliding door track. very rusty! DIDN'T KNOW TILL THE DOOR STARTED TO SQUEEK AND SQUEAL UPON CLOSING. TOOK A LOOK AND SURE'NUFF; NO RUG DAMAGE THOUGH, JUST THE PANEL. SWABBED OUT THE TRACK WITH LIGHT OIL ON A RAG....ALLS WELL FOR NOW. NOW LOOKING FOR THE LEAK!READ OTHERS SO WILL GO FORWARD WITH FINDING POINT OF ENTRY; OTHERWISE? THIS IS THE MOST AWSOME VEHICLE IVE EVER OWNED. I DRIVE THE 95 CORRIDOR OFTEN AND WITH A 26 GALLON TANK (OUCH) AND COMPUTER CONTROL, SAFE AT ANY SPEED. AND POWER? YOU BET. BUILT IN CANADA; DON'T KNOW IF THAT MEANS ANYTHING AS FAR AS QUALITY. I'M SECOND OWNER. BOUGHT AT CARMAX IN BOYNTON BEACH, FLA. IN 08.
    NUFF.
    CHUCK

    Reply
    Flag This
  • Answer #3

    Visitor, January 26, 2011, 17:33

    I had this problem too around 37,000 miles. I took it to the dealer and found there is a small drain hole which was clogged. It only took a miniute to clear it and there was no charge. This happened once again and I cleared it myself with a piece of wire.

    Reply
    Flag This