19
questions

The oil light comes on quite frequently to add a quart of oil. Is that normal? Its maybe every 6 wks or so.

Monday I was driving and my car started to not want to accelerate. I pulled over and it stated that the battery was bad. So when I go home (in the mountains) I changed it out with the new battery in my 2003 BMW 525I to see if this would correct the problem. The check engine and battery lights both went off and the car drove fine. Until Yesterday morning that is. I was driving and an error code of P0563 High Voltage, popped up and my car started to not want to accelerate and at one point went into limp mode. I unhooked the battery and the car shut off. That tells me that it is the alternator? BUt I just replaced the alternator 4 months ago. Is there any way that by using the battery from my BMW the voltage is out of range causing the car to act up? Or is it the alternator?
Please help me!!

First the plastic pull pulled off, then the cable core pulled out with very little force. So I cannot get to the cable where it is fastened to the latch under the hood. How do I unlatch it, short of cutting a hole in the hood.
The reason I need to get in there is the serptine belt is broke and the battery is dead. Thanks in advance for any help you can give me. Loren-2020

The plate number light is not functioning

just drove 325 miles, stopped twice started no problem. stopped again came out car will not start. all lights, door locks work, turn key all dash lights come on but nothing happens, no turn over. just nothing

In Fall took a long trip by car with out any issues. Upon retrun...a couple weeks the trans. began with problems..screeching and then limp mode. NEW TRANS in January. Out of the gate...hesitation on occasion, failure to shift into high, slipping, occasion rough shift..once threw my head back against head rest eventually locked up. Each time I took back for a look at..NOTHING! This happened off and on over weeks.
Currently, back at trans place. First they thought it was a bearing and was getting permission to replace with another trans....still under warranty. Since then, with in a hour or 2, they determined it is TCM and $600.00 to replace. If this was the contirbuting factor to initial failure will it have damaged current trans? will this correct issue? ( do you think? any other ideas? To my knowledge there was no leakage at all...had at my regular service center and they did not see any leakage.

I change my signal light switch and after that the SRS light is on I wonder if I can ciear it my self

No problem in drive after it starts. But starting is taking a while..

A repetitive clicking noise from behind the center area of the dash panel is usually caused by a broken stepper motor actuating arm. The actuating arm controls the direction of air flow in the climate control system. Disassembly of the center console will be required to access and change the broken arm with the updated, reinforced part.

Two weeks ago the dealership replaced the front thrust link bushings. Today because I was hearing a clattering in engine area, I was told that left catalytic converter needed to be replaced. It is just coincidence that after the work done two weeks ago in same area as catalytic converter and now catalytic converter is clattering? Yes, I do now have about 111565 miles on my 2003 C240.

a triangle sign with an exclamation mark appears, check engine light on, DTR, SRS ABS light are on. Suddenly happened. Radio and head and tail lights are okay.
Can you tell what all this means and is the car worth fixing?
Thank you

Car already has 200,000 miles.

My car won't start at all,...flashing DTR ...what does it mean