mass air flow / intake air temp is built into this, on 2006 Mercury Mountaineer

I have a Auto Computer Diagnostics not just a can reader the mass air flow reads 0.6 at idle and I run it up to 2000 to 2500 rpm it shows 1.4 to 1.6 so do you think that part is bad?? I do have a code P0113 that is telling me the air intake temp side is bad on that part of the MAF ,but no check eng light ,will that cause a misfire like on number 8 cyl and or others at times but not all the time and real bad gas mpg,I do have a 2006 Mercury Mountaineer Premier 4dr SUV 4.6L 8cyl and I'am having a real problem finding this part the ford dealer's don't have it or show a part number for it as you know mercury is no longer ,do you know where I might find this part and or part number I have pulled it and cleaned it with a MAF cleaner but its a no go can you help me thanks

by in Franklin, TN on April 04, 2013
1 answer 5 comments
ANSWER by on April 04, 2013
When first checked , (before first start of the day), does the AIT sensor read ambient air temp.?
COMMENT by on April 04, 2013
yes and runs fine until it warms up then the eng starts a little miss and though the acel. up and say around 45 mph but not all the time hesitates and a little misfire I would say and I check it and it throws a p0113 I would say it should throw more codes if a cyl is misfiring on idle the MAF is at 0.6 to a 1.0 which is a delay I know sorry I missed your ?? but I know the intake part of the MAF is reading nothing but high temp all the time that's the reason for P0113 and is integrated IAT sensor in the MAF
COMMENT by on April 05, 2013
Your answer first says 'yes' to ambient air temp , then says runs high all the time, I'm confused???
COMMENT by on April 06, 2013
I meant to to say it thows a code P0113 which is a high temp and or high voltage from the MAF ,but the MAF is running at idle at 0.6 to 1.0 and I run it up to about 2000 to 2500 rpm reading 1.4 or 1.6 ,but the air intake side is IAT of the MAF not working on my program that monitors the real time data from eng. ,all the coils spark plugs etc. check out and firing as I did a manual check and I did a bal check on the injectors to make sure my reading were right and I did found out from ford the the MAF and the IAT is integrated so I wounder if I am missing something or if just changing out the MAF will correct the problem on the IAT but the problem is I can't find out where to buy a MAF / IAT that's integrated as the parts people and I should say all of them ford parts ,Autozone etc do not show it integrated IAT
COMMENT by on April 10, 2013
Use OEM part. AVOID expensive problems, from cheaper aftermarket parts.
COMMENT by on April 10, 2013
I always do use OEM parts ,but ford parts does not have what I need and they can not find it or show it in the parts book no one here is reading my post ?? and it takes so long to get a reply ,,,this site is really slow and useless I will stick to the big ford site but thanks for your help as to what it was

Related Content