» » »

BMW Q&A

Ask Your Question

2004 BMW 525i Question: Loss of power, cigarette charger not working and right front parking light

 

Question

Corona04BMW525I, Sacramento, CA, February 22, 2011, 11:01
Profile_thumbnail
 Rookie

I have been to the shop many times and my nice tech says there's no stored codes for the loss of power when traveling on the fwy after kicking the gas, window lock issue, cigarette charger not working, air bag warning light going on and off and now my right front head light parking not working.

1 Answer
Flag This
  • Answer #1

    Chow February 25, 2011, 08:59
    Profile_thumbnail
     Master

    The parker should just be a bulb, its wear and tear.

    Could it be a faulty charger? there is a small inline glass fuse about 3amps, check to see if it has blown. The car itself has a 20A fuse in the trunk, the junction box behind the cover trim on the side. That could also have blown

    What sort of window lock issue, this is not common to me

    The power loss could be a number of things, are you using good quality fuel? is the tech using a proper bmw tester? the bmw tester can see about 40%more and do 80% more.

    Flag This
  • Reply

    Visitor, February 25, 2011, 09:17

    Bulb - excellent, i'll check it
    Charger - I'll check the fuse and the junction box.
    Window - the window warning keeps coming on. I asked my tech to look at it, he confirmed there was an issue, but could not figure out how to fix it because there were no stores codes. Nothing major, i guess.

    Loss of Power - yes, i only use the highest quality fuel. My vehicle has turned off a few times.
    1. I was in SF by the rail car tracks and my car would not turn on in the morning.
    2. Car would not turn/on/over, but lights and everything else went on. Battery was good and shop replaced a starter.
    3. Another time i forgot a bag of ice in my trunk and the car died. I towed it to the shop and he replaced some fuse.
    4. Vehicle turned off on the fwy, afte kicking the gas to speed up, engine still on and motor seemed to be shaking a bit. I turned the vehicle off, waited a while, turned the vehicle back on and drove off. Tech said no codes were stored and cold not recreate the issue.

    At times when I step on the gas, the vehicle does not respond and takes a while to speed up, as if gas doesnt flow through.

    I asked my tech if he had the BMW diag. tool and he said he did, but I'm starting to wonder... He depends on these codes and when there are none, he can't fix my vehicle.

    I've spent a lot of money and my vehicle drives and performs poorly. He says the vehicle runs fine, but i can feel the difference.

    Reply
    Flag This