Chevrolet Q&A

Ask Your Question

1999 Chevrolet 1500 Pickup Question: lack of power with a 1812 valve body code

 

Question

jude100, East Haven, CT, June 09, 2010, 17:34
 Rookie

truck had no power in passing gear and a shudder in the shifting so i changed the transmission now the shudder is gone and it shifts better but it still has no power,and I still have the valve body code.any ideas? this is a 4.3 v/6 automatic

2 Answers
Flag This
  • Medium-star Best Answer
    mastertech6371 June 09, 2010, 18:02
    Profile_thumbnail
     Master

    did you put a reman or junk yard trans in it.

    Roy

    Flag This
  • Reply

    jude100, June 09, 2010, 18:25
     Rookie

    good question it was a junk yard tranny and they sent me a second and still have the same issue exept the shudder is gone ( may have been the converter) but this is the second junk yard tranny and i still have the code and no power engine races to 4500 rpm and wont go over 50

    Flag This
  • Reply

    mastertech6371, June 09, 2010, 19:00
    Profile_thumbnail
     Master

    well, i suggest you take your origina old trans to a shop and have them bench rebuild the trans. make sure you tell them the problem so they can look harder inside for the problem. i buy them over the counter for about 750 with a converter.

    Roy

    Flag This
  • Reply

    jude100, June 09, 2010, 20:30
     Rookie

    thanks roy thats the way i wanted to go in the first place

    Flag This
  • Reply

    Visitor, February 21, 2011, 14:12

    i just did the water pump and leaking tranny pan in mine.. told on the way out that the pressure hose for the power steering fluid is leaking.. i just realized what to do.. what i already knew.. stop buying total garbage that domestic companies produce and stick to anything else.. honda, toyota, nissan, hell even subaru.. sorry but its totally true.. i tried to go american a couple times now and just get burned by junk.. door handles, water pumps, window motors, tranny problems, ( 03 taurus with 55k), etc.. done chevy, done ford, done chrysler, done dodge, all total crap.. see you die hards later.... in my honda

    Reply
    Flag This
  • Answer #2

    Visitor, June 28, 2010, 10:29

    I had da same prob so I replace da valve body & now it works like new. Try it I paid $350 for an aftermarkit. Just look for a TCC control valve body kit & tell dem u want compleat assembly with seal

    Reply
    Flag This