» » »

Honda Q&A

Ask Your Question

2009 Honda Accord Question: instrument lights are on (TPMS, ABS, VSA, Eng ck, seatbelt lt. OD/Spdmetr inop.

 

Question

Sammiesr1, Ridgecrest, CA, March 20, 2013, 10:01
 Rookie

I have a 2009 Honda Accord (V4) and the following instrument lights are on after startup.
TPMS, ABS, VSA, Engine Check Light, Seatbelt Light, Odometer/speedometer not working, Oil Life shows [----]. I have disconnected and reconnect battery. Vehicle runs fine. Check fuses all are good. What could be the problem?

2 Answers
Flag This
  • Answer #1

    ziptie12 March 21, 2013, 10:17
     Master

    Need to have an "all DTCs' scan done (all comp. systems not just PGM-FI) write down codes and clear each system individually. Then start back up and see which codes return. Most if not all codes set may be from an intermittent communications failure possibly due to voltage interuption. Best way to start,at least.

    Flag This
  • Reply

    Sammiesr1, March 21, 2013, 10:35
     Rookie

    Thank you for your response. When I connected the code tester it said it was unable to communicate with the DTC so I coundn't get any codes. is the a reason why it would not communicate?

    Flag This
  • Reply

    ziptie12, March 21, 2013, 18:10
     Master

    Possible blown fuse affecting the DLC.How many fuse/relay boxes did you check?And what type of tool are you testing with?

    Reply
    Flag This
  • Answer #2

    nafisa123 April 25, 2013, 15:41
     Rookie

    Hi, I have a 2008 civic and have the same issue. nobody can seem to find the solution. did you ever find out what caused this? or how the problem can be fixed? Thank you

    Flag This
  • Reply

    Sammiesr1, April 29, 2013, 07:16
     Rookie

    Yes, the problem was caused by the TPMS unit. I disconnected it and everything worked fine. Plugged it up and everything was wrong again. I installed a new one and all is fine. I hope this helps.

    Reply
    Flag This