» » »

Ford Q&A

Ask Your Question

1990 Ford Escort Question: i think something is wrong with my trottle body? im stumped

 

Question

88escortWoohoo, 1.9L 4 Cylinder, Knoxville, TN, April 28, 2013, 08:29
 Rookie

my car wont run properly in idle or driving, in idle car dies and runs roughly, car also acts like its not getting enough gas when trying to accelerate and falls on its face alot when trying to go through the gears, it sputs and putters really bad trying to drive around. almost reminds me of a bad carburator miss but this car car has no carburator haha i have changed the distributor cap and rotor button and the idle sensor and car still runs the same, and the fuel pump still functions fine as far as i can tell no problems with it and i have replaced the plugs and plug wires and the coil is fine. any suggestions at all??? i really dont wanna have to pull the whole throttle body off lol

1 Answer
Flag This
  • Answer #1

    Escort wagon May 08, 2013, 05:46
     Rookie

    I'm having the same problem. replaced fuel pump, it did go bad, fuel pressure regulator. NEW distributor, cap, rotor, plugs, wires, ICM, IAC, temp sensor, temp sensor switch. Happens usually after driving awhile. However, sometimes when I just turn the key and not try to start it the fuel pump kicks on and off and i can see rpm needle jump around. One time fuel pump ran for 30 seconds. with just key turned. I'm really stumped. still smell fuel vapor but not as bad when I first got it 6 months ago.

    Reply
    Flag This