» » »

Toyota Q&A

Ask Your Question

1995 Toyota Camry Question: I replaced the fuel pump and filter but it still will not start. EFI relay?

 

Question

sctt64, 2.2L 4 Cylinder, Houston, TX, May 05, 2013, 14:42
 Rookie

I have spark at plug wires and a new fuel pump and filter but it still just spins I don't hear the pump run when I turn on the key but I don't remember ever hearing it when it did run. I unhook the fuel line at the filter and it has pressure and when I spin it it let fuel out the filter.

2 Answers
Flag This
  • Answer #1

    May 05, 2013, 15:20
    Profile_thumbnail
     Master

    Timing belt may have slipped, engine out of time. Relay ok if pump runs and spark is ok. Good hot spark, jump a 1/2" gap?

    Reply
    Flag This
  • Answer #2

    May 07, 2013, 20:03
     Master

    Going along with wetrys' answer, does it seem to crank abnormally faster than it had before? Just something to observe.......timing belt older than 5 years or 60K miles?

    Flag This
  • Reply

    sctt64, May 15, 2013, 14:41
     Rookie

    No it spins normally just like before. Timing belt is only about 2 years old. The first night it wouldn't start I took off the fuel filter and blew it out with air and it started. I replaced fuel filter and it started. Next morning wouldn't start. I replaced fuel pump, relay and coil and still just spins. Friend told me it could be the ignition igniter but it $180 and I hate to guess for that much. I have good spark I think. Has me baffeled. Is there a way I can check to make sure fuel pump is working with a gauge? I don't hear it but I don't remeber ever hearing it before.

    Flag This
  • Reply

    pushrod, May 15, 2013, 14:57
    Profile_thumbnail
     Master

    The pump is under the back seat, lift it up and out of the way, or out of car, and listen for pump while someone cranks the engine. Check for battery voltage if capable. SURE ABOUT GOOD SPARK??

    Reply
    Flag This