Chevrolet Q&A

Ask Your Question

2004 Chevrolet Trailblazer Question: I have no gauges

 

Question

dippy2baround, 4.2L 6 Cylinder, Berkeley Springs, WV, December 23, 2009, 00:50
 Rookie

My 2004 Chevrolet Trailblazer 4X4 4.2lt 6cyc. is experiencing some instrument panel cluster problems.
While driving, my battery gauge, fuel gauge, oil pressure gauge, and temp gauge stopped working and bottomed out as if I had shut off the engine and removed the key. Most if not all of my warning lights came on also. I pulled over and did a reset by disconnecting the battery. That got rid of some of the warning lights, but the ABS, seatbelt, battery, and parking brake light stayed on and the 4 gauges mentioned previously were still not working. I also had it checked with device to read the cpu and all it says is error. I also have no four-wheel drive, and no stero

3 Answers
Flag This
  • Answer #1

    February 21, 2010, 15:40
    Profile_thumbnail
     Technician

    Hello, I've seen similar problems from a bad ignition switch, is that what you found to be the problem with yours too?

    Reply
    Flag This
  • Answer #2

    October 28, 2010, 07:04
    Profile_thumbnail
     Technician

    I've seen similar problem related to bad ignition switch as well but it will usually cause the entire cluster to go out temporarily instead of just part of it. The symptoms this person described sound like failure of a chip on the circuit board which is non-repairable. Best option would likely be to get a new cluster unfortunately. More information on Trailblazer instrument clusters can be found here - http://drspeedometer.com/services-i-offer/trailblazer-speedometer-repair

    Flag This
  • Reply

    Visitor, November 25, 2010, 14:45

    I AM HAVING THE SAME PROBLEM. MY TRAILBALZER STARTS UP BUT THE GAUGES AREN'T WORKING. THE BRAKE LIGH, ABS LIGHT, AIR BAG KIGHT AND THE BATTERY LIGHT STAYS ON. DID YOU FIND THE CAUSE AND HOW MUCH DID IT COST FOR REPAIR.
    WILLIAMFD@OPTONLINE.NET

    Reply
    Flag This
  • Answer #3

    November 25, 2010, 15:01
     Rookie

    I AM HAVING THE SAME PROBLEM. MY TRAILBALZER STARTS UP BUT THE GAUGES AREN'T WORKING. THE BRAKE LIGH, ABS LIGHT, AIR BAG KIGHT AND THE BATTERY LIGHT STAYS ON. DID YOU FIND THE CAUSE AND HOW MUCH DID IT COST FOR REPAIR.
    WILLIAMFD@OPTONLINE.NET

    Reply
    Flag This