Chevrolet Q&A

Ask Your Question

2006 Chevrolet Trailblazer Question: I have an 06 trailblazer that is somehow stuck in 4wd .

 

Question

clane_85, 4.2L 6 Cylinder, New Baltimore, MI, December 29, 2013, 18:34
 Rookie

When I select any other option on selector it flashes 2wd approx 10 times then just illyminates 4 high. No service light on selector lit . I have read encoder motor and front axel accuator could be the problem and quite common. I just need to know if there's a way to tell which one for sure it is. I don't want to do both if I don't have to. Also I checked fuse #8 under hood for tccm I believe and its good. For sure it four high can tell on tight turns. Also will swutch to auto correctly on selectorbut even in auto (as it says) its in 4 high all the time for sure. Please help me figure this out

2 Answers
Flag This
  • Answer #1

    G. T. Service Center (3154 Answers) , Stephenville, TX - (254) 638-3236
    ProfessorG December 29, 2013, 19:09
    Profile_thumbnail
     Master

    Have it scanned with a Tech2 and read the transfer case module for your fault.

    Flag This
  • Reply

    clane_85, December 29, 2013, 19:13
     Rookie

    The tech 2 will be able to pin point which one is at fault or it will just illiminate one like encoder moter or switch ? Thanks alot btw

    Flag This
  • Reply

    ProfessorG, December 29, 2013, 19:29
    Profile_thumbnail
     Master

    The Tech2 is the GM scanner used for diagnosing GM vehicles. Myself and many other independent shops have one and use it religiously for finding the proper fault on GM.

    Reply
    Flag This
  • Answer #2

    Greg's Orange Auto (12262 Answers) , Orange, CA - (714) 361-9386
    globalhelper December 30, 2013, 06:11
     Master

    never question the prof.

    Flag This
  • Reply

    ProfessorG, December 30, 2013, 06:19
    Profile_thumbnail
     Master

    Morning to ya! Should get a phone call about a M Benz no start.

    Flag This
  • Reply

    globalhelper, December 30, 2013, 06:23
     Master

    yes i saw that thanks.

    Flag This
  • Reply

    clane_85, December 30, 2013, 06:30
     Rookie

    Lol thanks to you all mates getting scanned in a few ok I got the car scan the mechanic size everything is operating correctly as far as the front axle actuator and the encoder motor. he claims is it is a bad wheel bearing and that is the result but my truck is still stuck in 4 wheel drive and I don't think that is correct can a bad wheel bearing prevent the 4wd from working properly? Or disengaging

    Flag This
  • Reply

    ProfessorG, December 31, 2013, 15:34
    Profile_thumbnail
     Master

    Not normally; Did it say anything about a bad ABS wheel sensor? Did they use a Tech2 scanner or another type. If your 4wd light is staying on and not change, there is a issue in the transfer case control. If they didn't use a tech2 they probably can't find it, if they used the Tech2 and didn't find a problem they need to go back to training on how to operate it.

    Flag This
  • Reply

    clane_85, December 31, 2013, 17:22
     Rookie

    Yes I believe so . Ill get details my wife took truck in but.didn't sound right. He told her that the wire come from the wheel bearing was cut in half and needed to be replaced and therefor whole hub assembly was bad ??? Everywhere I've read all said encoder motor accuator or switch. Ill find out details and get bk with you. Reputable shop but doesn't seam accurate to me

    Flag This
  • Reply

    ProfessorG, December 31, 2013, 19:48
    Profile_thumbnail
     Master

    Let Me Know, thanks

    Reply
    Flag This