» » »

Saturn Q&A

Ask Your Question

2002 Saturn SL1 Question: i have a cracked motor mount and my temperature gage doesn't work

 

Question

Freckles10, Collinsville, IL, May 17, 2011, 07:01
 Rookie

I know i have a cracked motor mount and need a new temperature gage

2 Answers
Flag This
  • Answer #1

    May 17, 2011, 07:10
    Profile_thumbnail
     Master

    which motor mount and do you have a gauge or a light??

    do you need a price or are you determining the failure??

    Roy

    Flag This
  • Reply

    Visitor, May 17, 2011, 07:11

    I am not sure.. I just know a guy told me i had a cracked motor mount due to my car banging when i start or shift gears.. and since that has started the Temp gage doesn't tell me if my car is hot or cold.. so I know it isn't working. I'm a blonde. lol

    It is a gage that tells me if it is H Or Cold

    Flag This
  • Reply

    mastertech6371, May 17, 2011, 07:24
    Profile_thumbnail
     Master

    the top front motor mount is the most common. it is a little pricy, around 90 for the mount and 1 hour in labor.

    the temp guage is cheaper if the sender is bad. it is around 30 for the part and .8 hours in labor.

    the check engine light will have to be diaged for the code and the failure. it is a process that can get expensive but you need a shop to do this for you.

    try our directory tab at the top for a shop near you.

    Roy

    Reply
    Flag This
  • Answer #2

    Visitor, May 17, 2011, 07:16

    Also, my check engine light has been on for quite sometime.. and I need to get my car inspected very soon as I have to get my sticker renewed.

    Reply
    Flag This