i have a 1996 toyota tacoma with starting problems on 1996 Toyota Tacoma

1996 toyota tacoma, 4 wheel drive, 2.7 engine, when cold the engine starts perfect, but when you shut id down, it will start back immediately, but if you let it set for 15 or 20 minutes it want start, i put a new fuel pump on it about 3 years ago, i put a different distributor shaft with coil on it, a new distributor cap, a new roller button, new wiring, new plugs, different EGR valve, took throttle body off and cleaned good and put new gaskets on that, a cold water sensor behind the engine, its broke me up, dont know what to do now, please help me if you can, THANKS

by in Harold, KY on May 27, 2012
1 answer
ANSWER by on January 23, 2013
I have the same problem did the same repair as you and still won't start hot and calls PO171 code im looking at replacing the fuel pump again
Related Items:
I would lik to replace the heater control valve on my 1996 toyota tacoma and am not sure where to start looking for it?
Turn the key and everything lights up but the start is dead. after a few more tries it starts. Replaced the ignition switch, no help.
Symptom: 1996 Tacoma 250,000 mi. Rough Idle- P0303 Cyl 3 miss fire. Adjusted valves- #3 was a zero lash- brought to spec. Cleared codes- Good drivibility several hundred miles, now P0303 is back a...
truck has always started, even without oil or water. but after being parked for a week it will not start. it cranks real good, but won't start. engine has close to 300,000 miles. Just pulled a plug...
pulled my truck into the garage, installed a new stereo, messed with the stereo with the car off and now it wont start, the battery is charged and everything works but the engine wont start