» » »

Mitsubishi Q&A

Ask Your Question

1996 Mitsubishi Eclipse Question: i have a 1996 eclipse gs and everything time im driving it stalls on me

 

Question

mralokatroniko, 2.0L 4 Cylinder, Orlando, FL, February 02, 2012, 21:09
 Rookie

i have a 1996 eclipse gs and everything time im driving it stalls on me and i fix eveything i could think it would be and it was not my problem i dont kno what do to..in order for me to turn on the car i have to disconnect the ecu plug cables and connected back in in order the car to turn on am so sick of this problem idk what to do.. plssss help me

i changed da filter
and fuel pump
i think is my ecu but how can i kno its me ecu messing up??

3 Answers
Flag This
  • Answer #1

    patrick mannion from Greg Solow's Engine Room, February 02, 2012, 21:51
    Profile_thumbnail
     Master

    I have heard of the Eclipse having ECU problems but I would nor replace it without being certain it has been tested and fails. With the engine running hit the ECU with your hand several times the engine should not stall if it does the ECU IS bad! There are several companies that can inspect/test/repair the ECU. I like Fuel Injection Corporation in Livermore CA, I have also used http://www.siaelec.com/ (they may only do American cars but I have had good luck with both these companies (bad luck with some others).
    There is a company that independent auto repair shops get their information from, this same information is available inexpensively for people that work on their own cars.. The information is year make and model specific, covering repair procedures, torque specifications, fluid capacities and specifications, service bulletins, component locations, wiring diagrams ect.... Alldata is very easy to navigate http://bit.ly/AllData_Repair_Manuals_Online

    Reply
    Flag This
  • Answer #2

    February 02, 2012, 23:00
     Enthusiast

    check your spark plugs and wires.and it also could be bad gas.so put some fuel treatment in the gas also.also check the distributor for cracks and burns if it has one.if it has coils check them to see if thay are getting out hot .if its not either one of those them it is your ICM.OR ECU

    Reply
    Flag This
  • Answer #3

    October 09, 2014, 09:11
     Rookie

    Do not replace ecu thats the first scapegoat for mechanics on this problem check sensors first camshaft position sensor crankshaft sensor then move on to ecu sensors are 50-100 ecu is around 500+

    Reply
    Flag This