I had the h2o pump replaced in my car. on 1998 Pontiac Sunfire

When I started to drive it away it sounded terrible. I only went a 1/2 a block. I went back in and told them... they came out and listened and said that the timing chain had broken. Did they put it back on properly when they fixed the h2o pump?

by in Spokane, WA on July 11, 2013
2 answers 2 comments
ANSWER by on July 11, 2013
if the timing chain broke the car would not run
ANSWER by on July 12, 2013
Agree with gg! Which engine, 2.2 belt driven pump or 2.4 chain driven pump?? IF the noise was not there before this repair, tell/ask the shop manager to explain in terms you understand!! Then post the results, if not satisfied, and we'll help.
COMMENT by on July 12, 2013
Thank you for your response. The noise was not there before and the car ran fine it just leaked coolant on the garage floor. I took it in because I was going on a trip and I did not want any problems. They called me during the repair and said that they timing chain was off and did I want to replace it now I asked how bad was it I was only going to keep the car for another nine months they said that in that case unless I was going to keep it for a long time it was just fine for at least another nine months and they would just put it back on. Any assistance in this would be greatly appreciated.
COMMENT by on July 12, 2013
If they felt the timimg componets needed to be replaced, they should have advised you of that, DID THEY? And then it was your choice not to have it done?

Related Content