Chevrolet Q&A

Ask Your Question

1994 Chevrolet Suburban 2500 Question: i changed my trans fluid and filter about a month ago.

 

Question

jdubb509, 5.7L V8, Kennewick, WA, April 06, 2012, 15:23
 Rookie

the truck ran fine for about a week, then started stuttering on take off from a stop. after that it started shaking and stuttering worse when id turn left. thot it was points, so i got a new cap and roter. ran great again for a couple of days then started doing it again. my wife when to yakima today and says that there is smoke comming out of the tale pipe now. whats wrong with my baby????/ please help.

im not a mechanic but i know the basics about care.

thx...johnny.j

1 Answer
Flag This
  • Answer #1

    Miles Auto Services (884 Answers) , Richmond, VA - (804) 885-4176
    milesauto April 07, 2012, 07:24
    Profile_thumbnail
     Master

    Best thing it get to a mechanic...all I could do is guess and I have been doing repair for many years. Probaly has no relation to changing trans fluid.

    Flag This
  • Reply

    jdubb5099, April 07, 2012, 15:29
     Rookie

    could it be my plug wiers touchen metal. the do arc when they touch and the truck runs like i explaines.

    Flag This
  • Reply

    milesauto, April 07, 2012, 15:53
    Profile_thumbnail
     Master

    Sure could be your problem.

    Flag This
  • Reply

    jdubb5099, April 10, 2012, 00:44
     Rookie

    think it was. moved wires away from all metal and re-gaped plugs. she is running fine for the time being.

    Flag This
  • Reply

    milesauto, April 10, 2012, 04:31
    Profile_thumbnail
     Master

    Next time it rains your miss may come back....reccomend you invest in a good quality set of cables...(A/CDelco makes a good set.)

    Reply
    Flag This