» » »

GMC Q&A

Ask Your Question

2006 GMC Envoy Question: How can I troubleshoot the aircompressor for the rear suspensions ?

 

Question

dutch 2, Sacramento, CA, May 23, 2012, 14:21
 Rookie

Air compressor for rear air springs fail, causing vehicle to sit very low every time car is turned off.

1 Answer
Flag This
  • Answer #1

    DougVoy September 22, 2014, 16:25
     Rookie

    Same problem as countless others. After just a few years the rear suspension loses air overnight. Takes a few minutes to pump back up. After more time, problems worsens, as suspension is lost while driving, etc. Many, on different forums, report that entire compressor and suspension bag components must be replaced. Shops claim the same, and charge $1500 to $2000 for repairs. Common report is that compressor cannot be repaired, but must be replaced. THIS IS NOT TRUE. Now, if your loss is consistent, and unchanging, then you might have faulty rubber or connections somewhere needing attention. Do the soapy water test to look for leaks, and do what you must. BUT, if you loss is intermittent in any sense, sometimes you find it low in the morning, but other times not, then 99% of the time, you have a faulty check valve in the compressor, AND THIS CAN BE REPAIRED EASILY. It is the hardest working element of the system, most likely to develop trouble, and easy to service. YOU NEED NOT EVEN REMOVE THE COMPRESSOR FROM THE VEHICLE. There is a service plate on the bottom of the compressor, removable with 2 T-25 torques screws. Pull it, and the plate, an oval O-ring, spring, and rubber check seal, will come out. Clean the remaining metal interface of all debris and built up rubber deposits. Don't use a file or scratch anything! Clean the o-ring surfaces, and the o-ring itself, including the inside of the metal external plate removed. The rubber check valve pad will likely have a shiny circle where it meets the metal of the compressor body. This hardened rubber doesn't seal like it used to. Get some 400 grit sandpaper, with a flat hard backing, and scrub the valve pad against it until the hardened circle disappears and you have a soft virgin rubber surface again. Apply a very thin coat of silicon grease to it, and the same grease heavier to the o-ring, and reassemble. Good as new. Plan on repeating every few years. It's the hardest working component, etc. Wish I could post this on all forums, but they make it difficult to share easy, and cheap solutions. Go ahead and pay $1500 at the shop, or $0.00 for this approach. Hope this helps someone. Took hella effort on my part to find out. But glad it won't bother me again.

    Reply
    Flag This