1999 Honda Civic Questions

All 1999 Honda Civic Questions

Ask a Question
just had the motor rebuild and i have all so tryed changing the ATF a few times it only helps for a few days the wright back on
I put a new catalytic converter in also changed the TPI. Also a new timing belt. When I drive on a flat it seems ok, but when I put the ac on the motor bogs down. I put a new radiator in also. It gets worse as the eng...
try to look for the wiper relay for replace, but couldn't find it, where is the wiper relay locate at ??
okay my civic has cylindar 3 misfire had a tune up been keeping oil up still misfires compression check said 120psi- #1,2 #3 had 30psi #4 had 80psi. need know what i need to fix it. along the lines of rebuilding it
oil light came on and then car died. Waited 15 minutes, it started up again but died when put it in gear. Tried to start it again, nothing. It would turn over, just not start. This is the first time anything like ...
help after restart it shifts again for 5min then stops
Honda civic runs great, but noticed a smell when driving for about 30 minutes and when parked after driving it. it is not a lot, about tennis ball size. Smell minimal like an over spill of oil.
just put used trans in
Driver side works fine. Passenger side tries to work for a split second.
The car was running them stop parked get out went return no instrument ligths or check engine,car won`t start.went turn the ignition key the cooling fan tunr on,no instrument ligths
I just replaced the radiator and the sensor that plugs directly into the thermostat (don't know why I can't think of the name of it). And now my car will not start, or go into gear. When I turn the key to the "on" po...
I recently replaced my radiator, and I hear this "honking" noise upon acceleration and at idle...I THINK it's coming from the resevoir...can anyone help?
i had recently changed the radiator in my honda civic, and when i put the coolant lines back on. i had transmission fluid coming out of the top of the bolt when i start the car. i have taken the bolt plug out, cleaned...
Monday car wouldn't start. Poured soda on battery & it started. Tuesday replaced starter and battery. Friday, same thing - car wouldn't start, poured soda on batter and it started. Is it the battery cables?
light comes on when ignition turned on and goes off, but comes on after engine starts but no codes, also srs lite stayes on also