» » »

Jeep Q&A

Ask Your Question

2004 Jeep Liberty Question: Hi yesterday it boiled now it will not run at idle and the plugs go black

 

Question

rovergunn, 3.7L V6, Wake Island, HI, January 19, 2014, 00:15
 Rookie

I have checked for blown head gasket no steam from exhaust no water in oil and no bubbles in radiator no water in cylinders, ?? i am at a loss

1 Answer
Flag This
  • Answer #1

    pushrod January 19, 2014, 02:58
    Profile_thumbnail
     Master

    Did you cook the engine? Just how hot did it get?

    Flag This
  • Reply

    rovergunn, January 19, 2014, 13:26
     Rookie

    hI it did boil over water went over the electrics thanks Chris

    Flag This
  • Reply

    pushrod, January 19, 2014, 13:28
    Profile_thumbnail
     Master

    Ok, in that case moisture is most likely the problem. Compressed air may be needed to dry it out.

    Flag This
  • Reply

    rovergunn, January 19, 2014, 14:40
     Rookie

    Yes did that I have just cleaned the plugs again and have it running missing like crazy but I can hear sucking noise could the heat worp the valley cover as it sounds like that's where it is coming from.Part two must be vacuum as my brakes are hard and after a new set of plugs they are black now idles very ruff and no power just back fires.
    plus now only one side of the radiator is hot r/hand side looking from front ?? i am at a loss.
    I need the car for back and forward to the doctors and cannot afford for mechanics only on pension so any answers would be great.

    Reply
    Flag This